PDA

View Full Version : New York Times web site


johnny0
2006-04-28, 12:37 AM
Aside from my opinion that the new NYT website is atrocious, has anyone figured out a way to make the article text bigger (i.e. readable) without making the columns (especially the left-most one) overlap?

I was hoping that OW 5.5 would help, but not even it cannot overcome the efforts of the million monkeys who were given keyboards to generate the NYT CSS...

Firefox displays the text more evenly (i.e. the left hand column text scales more reasonably, but it still spills over...) I imagine it is optimized for IE? Compare this to the latimes.com, globeandmail.ca, news.bbc.co.uk -- these size pretty evenly in any browser...

That being said, many websites these days seem to have small fonts -(due I think to the different DPI in Windows or something?).

Is this simply a WebKit issue? Kind of surprised that it doesn't account for the Windowsy-ness focus of some of these web sites.

Flounder
2006-04-28, 03:47 AM
Have you tried cmd + to make the text bigger or cmd - to make it smaller. Works fine with me on the NYTimes page.

Mad Hatter
2006-04-28, 05:16 AM
Have you tried site specific fonts, size, etc to try and get it more readable?

Even try presenting the browser as something else to see if that helps.

bitfactory
2006-04-28, 05:58 AM
I've only found one site that it exhibits odd behavior on. http://www.drudgereport.com - when it loads all the links turn this odd blue color. Only browser that does it.

johnny0
2006-04-28, 07:39 AM
That's the whole problem -- the only size where things look good is tiny. Hitting cmd + make some fonts grow more quickly that others. Watch the left hand size as you make fonts bigger.

http://www.nyt.com

JKT
2006-04-29, 03:46 AM
Just to save people the bother:

Normal font size:
http://homepage.mac.com/jtyzack/.Pictures/screenshots/NYT2.jpg

Bigger font size:
http://homepage.mac.com/jtyzack/.Pictures/screenshots/NYT.jpg

That really is shockingly bad for a national institution.

Flounder
2006-04-29, 03:57 AM
It also happens when using safari so it most likely isn't a OW problem but rather a NYTimes problem

Ilgaz
2006-05-08, 07:25 AM
NY Times site has its own problem which is shared by every browser on earth.

I remember seeing it mentioned on Slashdot about Hyatt's new suggestion about font size dilemma solution on very large (really!) displays by Mozilla users.

I can't remember exactly but one of the referenced sites was NY Times.

Forrest
2006-05-08, 08:31 AM
A custom stylesheet would probably do the trick.

Man, that is a messed up site. The gray they used is entirely too light. And this is coming from someone who does use gray type. I can barely read the photo caption.

The leading is horrible. The lack of thought behind how text would wrap is the trait of a novice. All of the lines forming multiple, misaligned columns and boxes also smells of someone who is just getting used to CSS. They littered the lower left column with non-essential information. Since the format is wider than 800px, non-essential info should go on the right. Oy...

Jesse the K
2006-11-08, 10:14 AM
Amen to the complaints on the new NYT site. Ever since OW adopted WebKit, however, I briefly see a "no styles", one column version before the page is completely loaded and the full hideous version appears.

I'm not .css savvy enough to know what's controlling the display, but could there be a site-specific setting that would suppress the ugly stylesheet and employ the less elegant, but much more readable, one-column version?

Here's my current workaround:

I copied this "print" bookmarklet to the start of my Favorites bar:

javascript:(function(){function%20linkIsSafe(h){re turn(!/^mailto:/.exec(h)&&!/^javascript:/.exec(h));}%20var%20i,x,h;%20for(i=0;x=document.ge tElementsByTagName('a')[i];i++)%20{%20h=x.innerHTML.toLowerCase();%20if(h.in dexOf('print')%3E-1%20&&%20h.indexOf('edition')==-1%20&&%20h.indexOf('subscri')==-1%20&&%20h.indexOf('reprint')==-1%20&&%20h.indexOf('text-only')==-1%20&&%20linkIsSafe(x.href))%20{%20x.focus();location=x. href;return;%20}}%20alert(%22Can't%20find%20link%2 0to%20printer%20friendly%20version.%22);})()

When I see an article worth reading then command-1 quickly displays a legible version.

troyb
2006-11-13, 03:00 PM
You should be able to block all css via the black list by adding this line:

/graphics8\.nytimes\.com/css/

You could also look in page info and try blocking just the particular css file that's causing the layout problem you want to get rid of.