The Omni Group Forums

The Omni Group Forums (
-   OmniFocus 1 for Mac (
-   -   Extreme Caution: 1.8.2 Upgrade problem - Data unreadable (

RobTrew 2010-11-25 02:46 AM

Extreme Caution: 1.8.2 Upgrade problem - Data unreadable
Just ran the upgrade to OF 1.8.2

The result has been long series of warning dialogs:

"Warning encountered while loading XML"

and the "Opening OmniFocus Document" wheel never terminates.

Have tried closing and reopening OF 1.8.2 a few times, but still can't load any data ...

Probably worth exercising some caution with this upgrade.

(Restore from backup also fails)

acetuk 2010-11-25 02:52 AM

No problem here. 1.8.2 installed, Omnifocus restarted and the data is fine.

Just tried closing OF and restarting it to be sure and it seems fine again.

RobTrew 2010-11-25 03:23 AM

Restore from backup turns out to work if I go back to Nov 16th.

All backups after 16th, if opened by double-clicking in the Finder, provoke an error of the form:

The document “OmniFocus 2010-11-20 012215.ofocus-backup” could not be opened. xmlParseCharRef: invalid xmlChar value 55552

[I]Nov 25 13:39:19 Macintosh-8 OmniFocus[1025]: Presenting modal error: {\n code = 9;\n domain = "com.omnigroup.framework.OmniFoundation.ErrorDomain";\n userInfo = {\n NSLocalizedDescription = "Warning encountered while loading XML.";\n NSLocalizedFailureReason = "xmlParseCharRef: invalid xmlChar value 55552\n";\n "libxml_code" = 9;\n "libxml_domain" = 1;\n "libxml_int1" = 55552;\n "libxml_int2" = 684;\n };\n}[/I]

A relief to to get to some data, but a little worrying to know that OF has been writing out unreadable backups for several days ...


FatalError 2010-11-25 04:01 AM

update went ok for me without any issues.

RobTrew 2010-11-25 06:23 AM

Even after reverting to a backup from 9 days ago, everything works for a while, and then the XML error messages begin again and connection to data is lost - possibly the (newly ?) unparseable character in the old data is getting picked up again by synchronisation with the Mobile Me server ?

(Switching of synchronisation does seem to prevent the regression)


Brian 2010-11-25 10:29 AM

Sorry for the trouble here, Rob. I suspect what's going on here is that there's a corrupt transaction file in the server DB. That's why the error messages come back after a sync.

When an updated version of OmniFocus is launched, it invalidates the cache and builds a new one from your transaction files. 1.8.2 uncovered the bad transaction during the rebuild, in other words, but it didn't do anything new to your data. This happened to be the first rebuild since the transaction file went bad.

That bad transaction file is preventing OmniFocus from completing the rebuild, but that's all the error message means - that the rebuild can't finish. Repairing the database needs to be done manually, but I'm getting you some help.

RobTrew 2010-11-25 03:15 PM

[QUOTE=Brian;89433]Repairing the database needs to be done manually, but I'm getting you some help.[/QUOTE]

It's heroic of you all to respond at Thanksgiving - thank you - I really appreciate that.

The unparseable transaction turned to contain non-textual data which had been pasted into a note field during a scripting experiment. Having removed this my data is now loading without a problem.


All times are GMT -8. The time now is 05:47 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.