The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   Bonjour sync (http://forums.omnigroup.com/forumdisplay.php?f=55)
-   -   Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync] (http://forums.omnigroup.com/showthread.php?t=11249)

ajgilbert 2009-02-05 05:20 PM

Sync Stopped Working Using Bonjour [SOLVED: Firewall on Mac blocking sync]
 
Up until a few days ago, my sync between my iPhone and my laptop (using Bonjour) was working great. Then, for some reason, it stopped. After about two minutes I get an error message: "Unable to synchronize database with server. timed out" I have rebooted both devices and done a "Reset Database" on the iPhone. Still, I cannot get them to sync.

The laptop is running 1.5 and the iPhone is running 1.1.4.

Any suggestions?

Brian 2009-02-05 05:27 PM

Use the steps in the "setting up a computer-to-computer network" topic of Mac Help to directly connect your Mac to the iPhone - does sync work now? If so, something about your wireless network configuration changed that's preventing OmniFocus on the iPhone from connecting to your Mac.

If the computer-to-computer connection isn't working, I'd start looking to see if the firewall settings in System Preferences on your Mac had changed, or if Little Snitch or some other software that could be blocking the connection was active.

If *that* doesn't turn up any results, send an email to the support ninjas and we'll be happy to work with you and figure out what's going on.

ajgilbert 2009-02-05 06:03 PM

Success! I had changed my firewall settings to "Allow only essential services" about the time that sync stopped working. Switched back to "Allow all incoming connections", and bingo! Thank you.

Brian 2009-02-05 06:08 PM

Happy to help - I'd recommend, though, that you use the "Set access for specific services and applications" option, though. That lets you allow OmniFocus to talk through the firewall, but blocks other applications from doing so.

Think of it like giving a trusted friend a key to your house vs. leaving the door unlocked entirely. With the current setting, the door's unlocked. :-)

cdg@home 2009-06-21 09:46 AM

Ah ha! same problem/ same fix ... and same thought on using firewall correctly
 
This post helped me solve the same issue. After realizing I didn't have the firewall turned on I turned on the Firewall with "Allow only essential services" - I should have realized blocking incoming connections would block things like OmniFind sync.

Brian - right on the money about locking the door - it was easy enough to "set access for specific services & applications" and add the ones I know I trust - OmniFocus being one of them. I'm back in sync - thanks for the tip. I can't wait to try out the 1.5 update on the iPhone 3.0 update.


All times are GMT -8. The time now is 03:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.