The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Convert to black & white not working? [Bug filed] (http://forums.omnigroup.com/showthread.php?t=12570)

Schlaefer 2009-05-19 12:18 AM

Convert to black & white not working? [Bug filed]
 
Is it just me or does the 'Convert to black & white' option for printing shows no effect (OF 1.6.1)?

webalstrom 2009-05-19 05:09 AM

It has no effect for me and never has. I always get color when I print, although since I'm using a b/w laser printer, it turns out lighter shades of gray. Kind of annoying, but not as bad as if I was on a color printer. On my daily task list I don't like seeing the color... just what needs to be done. (And on that note, I wish I could have the option to turn the various date, flag and now recurring columns off when I print).

Eric

whpalmer4 2009-05-19 08:48 AM

I don't bother with the OmniFocus option (which seems to be broken for me as well). Instead, go to the ColorSync options in the print dialog, select Color Conversion: Standard and Quartz Filter: Black & White.

derekr 2009-05-19 10:14 AM

Through some initial testing it appears that resetting to the default OmniFocus style will fix the issue. I have filed a bug report, though.

If you don't find that to be the case, let us know so we can add additional information!

Schlaefer 2009-05-19 11:27 PM

[QUOTE=derekr;60052]
If you don't find that to be the case, let us know so we can add additional information![/QUOTE]

Ok, maybe my mistake. I was printing out a list with all project names (all projects collapsed, no actions visible). So, I didn't noticed the following: if the option is on it converts the text color of actions to black. This works for the standard theme and my theme.

What I was looking for was (from the OF help): [I]'Ignore OmniFocus’s color styling and draw all text in black [B]on a white background[/B].'
[/I]

White backgrounds don't work neither if I reset to the standard theme (headers still gray in print) nor in my theme (headers and body in theme color).

So something is working, something is not. If the background should be white, it's a bug, if it shouldn't, this would be a feature request. ;)

Schlaefer 2009-05-19 11:53 PM

[QUOTE=whpalmer4;60049]I don't bother with the OmniFocus option (which seems to be broken for me as well). Instead, go to the ColorSync options in the print dialog, select Color Conversion: Standard and Quartz Filter: Black & White.[/QUOTE]

Mhm, I can choose ColorSync for color correction but can't find the dropdown for ColorSync filters anymore. Strange.

webalstrom 2009-05-20 06:34 AM

[QUOTE=derekr;60052]Through some initial testing it appears that resetting to the default OmniFocus style will fix the issue. I have filed a bug report, though.

If you don't find that to be the case, let us know so we can add additional information![/QUOTE]

I tried doing what you suggest (assuming what you mean is resetting my saved theme with the default one... themes = styles?).

First, I had a heck of a time resetting my styles. OF crashed whenever I hit the big reset button at the bottom of the preference window. I could change each style individually with out a crash by choosing one (i.e. Sidebar or Groupings) and using the pull down menu option to "Reset Selected Styles". When I tried to change all of the Main Outline styles at once it also crashed. I finally switched to my Inbox (instead of the full library) and that might have let me reset styles a bit quicker. But by the time I switched to the Inbox, I was resetting one style at a time.

So after finally resetting the styles, I went to Page Setup -> Settings -> Omnifocus and the "Convert to Black and White" was no longer checked off. I did a quick test print (via Preview, not actual paper -- does that make a difference? I wouldn't think so) and, as I would guess, it was in color. I went back to the OF Page Setup settings, checked the "Convert" box, did another test print and... it was still in color.

So, at least for me, your trick didn't work. Or I didn't reset everything because of those OF crashes. I'll try again when tomorrow after I shut down/restart my iBook and see if that changes anything. I'll let you know if it does.

Eric

derekr 2009-05-20 09:08 AM

[QUOTE=webalstrom;60092]I tried doing what you suggest (assuming what you mean is resetting my saved theme with the default one... themes = styles?).

So, at least for me, your trick didn't work. Or I didn't reset everything because of those OF crashes. I'll try again when tomorrow after I shut down/restart my iBook and see if that changes anything. I'll let you know if it does.

Eric[/QUOTE]

Thanks Eric. Would you mind sending in an email with a few more details about your setup—OS, your saved theme file, etc. You can send it to [EMAIL="omnifocus@omnigroup.com"]omnifocus@omnigroup.com[/EMAIL].

The more information gathered, the better!


All times are GMT -8. The time now is 06:52 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.