The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus Syncing (http://forums.omnigroup.com/forumdisplay.php?f=50)
-   -   SOLVED: Sync always triggers "no longer compatible" message (http://forums.omnigroup.com/showthread.php?t=8859)

IntlOrange 2008-07-19 07:48 AM

SOLVED: Sync always triggers "no longer compatible" message
 
I can sync my OF desktop via WebDAV. And then I can retrieve that info via sync with OF iPhone. But as soon as I add a task to either the desktop or iPhone version, and then attempt to sync on iPhone, I get the message:

"Your database couldn't be synchronized, because the server and the local version are no longer compatible..."

So, in effect, I can "sync" only one-way, as I have to choose to use either the local or server copy.

I am using the absolute latest updates of both apps. (Downloaded build 103077 for the desktop this morning, and the latest iPhone update, too, which I assume is 1.0.1.)

john36 2008-07-19 09:25 AM

I have the same problem (although I don't use an iPhone). On first try Omnifocus manages to write its file to the WebDAV server without any error messages (if the file doesn't already exist), but every subsequent try leads to the error message "Your database couldn't be synchronized, because the database on the server appears to be totally unrelated to the local database". This occurs even if I try to resynchronize without having made any changes at all.

The only useful error message I could find in the logs is
"Error Content-Type doesn't have two components (mime-type; charset)"
But I have no idea what that means...

I'm running the 17th July sneaky peek. My WebDAV server doesn't run on a standard port, but that doesn't appear to be the problem (since connecting to the server doesn't seem to be an issue).

Andrew 2008-07-19 10:36 AM

IntlOrange: This may well be a problem on the phone side. We have some workarounds for some bugs in some WebDAV servers (and I think at least one of our own bugs) in version 1.0.1 for the iPhone. However, as of this writing, Apple has not yet completed their review of version 1.0.1. We all eagerly await them releasing this version.

john36: please report this to our support team if you haven't already (via the Send Feedback item in the Help menu), along with info about what web host you are using for WebDAV. They may have a workaround for you, or may already know about this bug in which case your report will help elevate its priority and/or help us diagnose it if we haven't already, or this may be a new bug that we aren't familiar with in which case your report will be very valuable in identifying and hopefully isolating and fixing this.

-andrew

IntlOrange 2008-07-20 06:15 AM

Thanks, Andrew. iTunes downloaded an OF update for me yesterday -- i assumed it was 1.0.1, but I guess it wasn't. (Maybe it was 1.0.0.1?) I look forward to the update.

Andrew 2008-07-20 08:58 AM

iTunes has been showing updates that aren't actually updates. See this thread for a few examples: [url]http://forums.omnigroup.com/showthread.php?t=8867[/url]

You can check the version number on the App Store page or (once downloaded) at the bottom of the OmniFocus Settings screen. It's still 1.0 - it should show 1.0.1 when Apple manages to push the actual update.

anders.holm 2008-07-21 04:53 AM

Hi,

I have exactly the same problem. It seems like it is connected to the fact that my WebDAV service ([url]www.storegate.se[/url]) changes it http authentication realm at random times.

Perhaps OF stores some hash of the server as an ID and then a mismatch occurs.

Logs on the iPhone??

/Anders Holm

IntlOrange 2008-07-23 10:39 AM

Hooray! Got the 1.0.1 update and it looks like syncing is working for me for the first time. iPhone-entered actions move to the Mac, and vice versa.

Syncing seems to rearrange the display order of some of my projects on the Mac side (weird), but that's a separate issue. I'll investigate and start a new thread if it's an issue. Thanks, Omni folks!


All times are GMT -8. The time now is 06:04 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.