The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Omniweb Crashes (http://forums.omnigroup.com/showthread.php?t=3958)

kadams9181 2007-06-25 12:36 PM

Omniweb Crashes
 
I was noticing that Omniweb was crashing a lot of times and couldn't figure out what was going on.

I turn java on/off a lot to get that tiny performance boost and, for some reason, each time I would restart Omniweb after turning Java off it would crash and would continue to crash every time I tried to start it. In fact the only way out of this 'crashing' loop was to trash the prefs, and of course, lose all window customizations, shortcuts, etc.

So I came up with a 'kludge' that allows me to recover when this happens.

First of all, make a backup of your prefs file 'com.omnigroup.OmniWeb5.plist' and place it in the ~Library/Application Support/Omniweb folder.

Then, if you get into an endless crashing loop at startup, you can just replace the omniweb prefs file in ~Library/Preferences with this copy. That will allow you to restart Omniweb and retain all of your window customizations, shortcuts, etc.

Also, every time I quit Omniweb, I select preferences from the OmniWeb menu and make sure that enable java is selected. This will stop the repetitive crash that is occurring on my machine at startup that is, somehow, related to Java. I don't know if this type of crash is occurring on other machines or just mine.

I still have random crashes that occur at other times that I can't explain, but at least, I can recover from that startup crashing loop that occasionally occurs by using this method.

Perhaps others can tell me if they are experiencing crashes that are related to java.


All times are GMT -8. The time now is 10:00 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.