The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Service, omnifocus and keychain (http://forums.omnigroup.com/showthread.php?t=29157)

Chris Short 2013-04-16 06:58 PM

Service, omnifocus and keychain
 
Using the service "Send to Inbox" fails in Mail, but not other apps, (OS - Mountain Lion) if omnifocus is not open with the following message:

"OmniFocus cannot connect to Keychain to retrieve the password needed to sync your database.

To fix the connection with Keychain, please try quitting and reopening OmniFocus."

This does not appear to be a sync issue discussed elsewhere - I have no keychain related sync challenges.

It may have done it before mountain lion - it's done it for a while - I just thought I'd followup today, but couldn't find the issue discussed elsewhere in the forum.

Any suggestions? (besides leaving Omnifocus running all the time... :-)

thanks
Chris

Lizard 2013-04-17 08:36 AM

This is related to a quirk with 10.8 which we've reported to Apple. That error message is supposed to be slightly less terrible than prompting you for your sync credentials over and over again and never doing anything useful with them.

When launched by another app, OmniFocus doesn't always get keychain access like it should, so leaving OmniFocus running all the time is probably the simplest workaround.

Chris Short 2013-04-17 10:29 PM

thanks - much appreciated


All times are GMT -8. The time now is 02:40 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.