The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Mail clipping: no attachments in Lion [A: caused by change to Mail.app in 10.7] (http://forums.omnigroup.com/showthread.php?t=21718)

StefMercury 2011-08-21 09:36 AM

+1 -- under Lion, email attachments are NOT going into actions! This is a big deal for me. Surely this is an easy one for the Omnigroup to test and provide a fix?

fullcity 2011-08-22 08:09 AM

I'm not able to get the Clip-o-tron to copy anything over to Mail.

[QUOTE]Errors returned from handler <ScriptHandler:0x88e710 com.omnigroup.OmniFocus.ScriptHandler.Mail_with_MailTags NSBundle </Applications/OmniFocus.app/Contents/PlugIns/BuiltInClippingHandlers.plugin> (not yet loaded)>: {
NSAppleScriptErrorAppName = Mail;
NSAppleScriptErrorBriefMessage = "Can\U2019t get project of message id 537379 of mailbox \"INBOX\" of account \"FullCity\".";
NSAppleScriptErrorMessage = "Mail got an error: Can\U2019t get project of message id 537379 of mailbox \"INBOX\" of account \"FullCity\".";
NSAppleScriptErrorNumber = -1728;
NSAppleScriptErrorRange = NSRange: {3139, 7};
}[/QUOTE]

Greg Jones 2011-08-22 08:37 AM

[quote]I'm not able to get the Clip-o-tron to copy anything over to Mail.[/quote]

You'll need to uncheck the Mail with MailTags option in the OmniFocus clipping preference. The internal OmniFocus script plugin, or MailTags, or both, are not working together in Lion.

Brian 2011-08-23 02:22 PM

My understanding is that the early preview builds of MailTags 3 removed support for AppleScript. Since our clipping plugins depend on AppleScript, they broke.

I think I saw someone say on Twitter that the most recent MailTags 3 release restored AppleScript support. If so, installing that build should fix this.

I'm not a MailTags user, though, so please take this with a giant grain of salt until someone with actual experience with the app chimes in. :-)

Lizard 2011-08-25 01:29 PM

The other issue we're facing is that Mail in Lion does not support the approach we were using to retrieve Mail attachments in Snow Leopard.

Guy Bjerke 2011-08-25 02:26 PM

I found today that if I disabled the Clip-o-tron in OF it then worked in Mail and vis-versa. Still no attachments, but emails ended up in OF. Weird.

jgrafix 2011-08-30 06:09 AM

MailTags still doesn't have AppleScript support that I can see.

However, as far as I can tell, that should have nothing to do with missing attachments. I have disabled the Mail with MailTags option since it was throwing errors. The attachments still don't come over. I agree with the rest, this is a huge problem for me.

whpalmer4 2011-08-30 06:27 AM

You saw Lizard's post saying that Apple removed the mechanism they had been using to get the attachments, right? Without a new version of OmniFocus, I don't think you are going to see attachments just magically start appearing...

LuMe96 2011-09-07 03:09 AM

Hi,

I don't know about Clip-O-Tron. I wanted some customization so I wrote my own Applescript to create tasks from Mail and adding attachments works fine with my script.

It's part of a larger library but if some people are interested, I might find some time to make it stand-alone and share it.

Just let me know.

Bye

Brian 2011-09-07 03:14 PM

LuMe96, if you haven't already, it would be awesome if you could send a copy of your script to [EMAIL="omnifocus@omnigroup.com"]omnifocus@omnigroup.com[/EMAIL] - just in case you've found a method that the other folks on the team hadn't seen when they were looking at this previously. Thanks for the help!


All times are GMT -8. The time now is 09:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.