The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus Syncing (http://forums.omnigroup.com/forumdisplay.php?f=50)
-   -   "me.com" requires authentication - over & over & ... (http://forums.omnigroup.com/showthread.php?t=9634)

Ward 2008-08-28 12:18 PM

"me.com" requires authentication - over & over & ...
 
Last night, I enabled syncing between my desktop Mac and iBook using MobileMe as the sync server. It seemed to be working fine until an hour ago when I logged out and back in.

At launch, OmniFocus reported twice (in rapid succession):[INDENT]"me.com" requires authentication.[/INDENT]Each time, I entered my username and password and checked Remember in Keychain.

About five minutes ago, it asked again, twice, and I dutifully obeyed. And then, while I was starting to write this note, it asked AGAIN!

I took a break from writing to Cancel the authentication -- an exclamation point appeared in the Sync button. So I pushed Sync again. This time I got to fill in the dialog three times.

I can completely understand that MobileMe may be misbehaving right now and failing to authenticate. If that's the case, OmniFocus should at least be honoring my request and use my username and password from my keychain.

The sync at 4:12 PM apparently worked. Let's see what happens at 5:12 PM.

[SIZE="1"][submitted as formal feedback][/SIZE]

Ward 2008-08-28 12:36 PM

I've had enuf for now
 
As soon as I touched OmniFocus to do some updating, it asked to authenticate again. I clicked Cancel. A minute later, it asked again. It took a few cycles before I realized Cancel is an infinite loop.

I've turned off Sync for now. When I can find the time, I'll try syncing with my WebDAV server. The warnings about WebDAV problems are a disincentive.

Lizard 2008-08-28 09:48 PM

I don't know if it's been addressed, but at least for a while, there was a bug where if you entered a wrong username/password once, we'd keep pulling that data from Keychain even after prompting you for new login info. So it may be worth checking if an incorrect MobileMe entry exists in Keychain and deleting it.

Ward 2008-08-29 07:56 AM

Syncing quietly in 1.1SP 104457
 
I double checked my MobileMe account and password - that's not the problem.

The release notes for the 104457 mentioned sync updates, which encouraged me to try again:[LIST][*]On my iBook (Tiger), I had not turned off syncing. I got one authentication request before updating. After updating, Sync quietly did its thing.
[*]On my desktop (Leopard), I did the SP update and then reenabled Sync. It got an authentication request (blank fields), which I filled in and checked Remember in Keychain. The Syncing progress bar appeared in the prefs panel. When the progress bar got to 25%, another blank authentication request appeared, which I filled in.[/LIST]Since then, the desktop Mac did an auto-sync quietly (no authentication request), and I've done a manual Sync Now on both Macs. All quiet for now.

Ward 2008-08-30 07:28 AM

Regression on one Mac but not the other
 
I updated to 1.1SP 104461 on my Leopard desktop (last night) and my Tiger iBook (a few minutes ago).

When I awoke my desktop Mac from screen sleep this morning, I was greeted by a me.com authentication request, plus two more in rapid succession. When I do a manual Sync Now, I have to fill in two authentication requests each time.

The iBook is running smoothly. Right after the update, I got one request to transfer Keychain info to the new OmniFocus SP release. That's it; no authentication requests.

What's different between the two Macs?[LIST][*]desktop: Leopard, 6 Keychains (login, Ward, 1Password, ChronoAgentLocalKeychain, System, System Roots)[*]iBook: Tiger, 3 Keychains (login, System, X509Anchors)[/LIST]The iBook's login keychain has an entry for "idisk.me.com". The desktop keychains have no corresponding entry.

It appears OmniFocus is not saving my MobileMe authentication. I have no idea why.

Ward 2008-08-30 08:42 AM

Handcrafted Keychain item doesn't help
 
At the next hourly auto-sync, OmniFocus again requested several authentications. Sigh.

I manually created a "ward" Keychain item on my desktop Mac, mimicking the item on my iBook. A manual Sync Now didn't use this new Keychain item because I got four authentication requests.

I'm giving up on MobileMe until someone can figure out what's going on. I've unregistered both Macs as Clients.

Ward 2008-08-30 09:05 AM

One more difference: OmniFocus folder
 
While [URL="http://forums.omnigroup.com/showthread.php?t=9667"]experimenting with WebDAV syncing[/URL], I realized one more difference between my two Macs:[LIST][*]desktop: OmniFocus is in my "3rd Party Applications" folder[*]iBook: OmniFocus is in my "Applications" folder[/LIST]Perhaps this is a useful clue.


All times are GMT -8. The time now is 11:46 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.