The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Reload when following link to the same page (http://forums.omnigroup.com/showthread.php?t=2377)

calidius 2006-12-11 03:28 PM

Reload when following link to the same page
 
In 5.5.2 beta 2 I noticed that, when following a link to another part of the page currently loaded (that is, coded as <a href="#target"></a>), the page is reloaded from the server. As far as I recall, older versions of OmniWeb used the cached version of the page and jumped instantly to the link target, as do all other browsers. Bug or a new preference overlooked by me?

Example: Links on top of [url]http://www.thelatinlibrary.com/ammianus/29.shtml[/url]

Forrest 2006-12-11 03:33 PM

Your example (and thank you for the example) doesn't reload here.

calidius 2006-12-11 10:07 PM

Thank you for checking. I changed "Preferences/History/Validate cached content:" from "automatically" to "rarely", but still get reloads, e. g. on every Wikipedia page with a table of contents (like [url]http://en.wikipedia.org/wiki/Omniweb[/url])

[B]Update[/B]: the reload occurs when "Tab and Window Preferences/Links within the same site" is set to "Open in the current window". When changed to "Work as specified in the web page", the cache is used. Perhaps "Tab and Window Preferences" should now be site-specific?


All times are GMT -8. The time now is 06:48 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.