The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus Syncing (http://forums.omnigroup.com/forumdisplay.php?f=50)
-   -   OF for iPhone: Turning sync off/back on causes "No Root" error [FIXED-install v1.2.3] (http://forums.omnigroup.com/showthread.php?t=12064)

ajr 2009-04-13 07:27 AM

OF for iPhone: Turning sync off/back on causes "No Root" error [FIXED-install v1.2.3]
 
In case anyone is still having trouble w/ this error:

I got the "No root can reach all tail transactions" problem a few days ago. I regularly sync via Bonjour from my laptop to my iPhone and decided to try adding my desktop to the mix. As soon as I tried to sync from the desktop I got the error. Then when I tried to sync the iPhone, the error appeared on the iPhone.

I'm up to date on all devices, yet the error was not resolved automatically.

I ran the script manually and got this error:

"Unable to automatically repair database, multiple roots have descendents"

So, I see that there's something else going on but I couldn't find a resolution to this anywhere on the forum. I'm guessing the script just doesn't have a way of determining how to resolve the branching.

I finally got sync working by resetting the iPhone db, turning sync in OF off and then on (no restart necessary), and then syncing to the iPhone.

T

Brian 2009-04-29 03:33 PM

AJR, I'm really sorry for the trouble this caused. I checked with Ken on this - it's the same error message as the original "no root" issue, but it's not the same problem, which is why the script in that thread didn't work. (The script will only fix the specific problem from 2008; it won't fix every problem with this error message.)

According to Ken, when sync is turned off on the phone, it compacts the database (which makes sense, at that point, since no other devices are syncing).

The problem occurs when sync is turned back on on; instead of presenting the "Do you want to use the server database or the local database" dialog that's supposed to be shown, OmniFocus for iPhone adds the compacted database to the one that's already on the server. That's how you end up with two root files in your sync database and get the error message.

We're getting a new build ready to submit to Apple that fixes this problem.

If this happens to anyone else in the meantime, the fix is to rename the sync database on the server from "OmniFocus.ofocus" to something like "Old-OmniFocus.ofocus".

You can then re-sync your devices with the server, starting with the one that has the most up-to-date information. (When the 2nd and subsequent devices pop up that "Server or Local" dialog, you want to choose Server.)

Since this is a separate problem, I'm moving your post into a new thread, with a title that hopefully makes it easier for other folks to find.


All times are GMT -8. The time now is 06:57 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.