The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Update to Lion/10.7 disables mail clipping [A: reinstall plugin from OF's prefs] (http://forums.omnigroup.com/showthread.php?t=21671)

stevenjohn 2011-07-21 09:52 AM

Update to Lion/10.7 disables mail clipping [A: reinstall plugin from OF's prefs]
 
Hi there,

So far I cannot get mail clipping to work with Lion. Has anyone else had success here, or do we need to wait for an OF update?

Kind regards, Steve.

walterbriggs 2011-07-21 12:31 PM

You have to "reinstall" the Clip-o-Tron 3000 (button on bottom right of clippings OF pref pane.)

Then it works!

Christopher 2011-07-22 07:10 AM

Thanks - that worked perfectly for me.

johnbramhall 2011-07-22 09:46 AM

Except that attachments seem not to be transferred into Omnifocus using Lion - there are some difficulties with Lion transmitting email passwords, so this might be a function of using POP protocol instead of IMAP - but it would be good t hear if this is a general problem with Lion.

Jody Severson 2011-07-22 11:12 AM

Lion clip o tron not working
 
I discovered you also have to make sure that the Omnifocus/send to inbox option is checked in preferences/keyboard/keyboard shortcuts.

Brian 2011-07-22 12:36 PM

Sorry for the extra step that's required: whenever the Mail application is updated, it disables all the Mail plug-ins that are installed, even if they work fine. This is what stops the clip-o-tron from working as it was previously.

As folks mentioned, reinstalling the clip-o-tron from OmniFocus' preferences gets you back up and running.

joi 2011-07-24 10:48 PM

Giving me an error
 
I've tried to install the new plugin in Lion, but I'm getting this error:

The script handler failed.

Errors returned from handler <ScriptHandler:0xe41590 com.omnigroup.OmniFocus.ScriptHandler.Mail_with_MailTags NSBundle </Applications/OmniFocus.app/Contents/PlugIns/BuiltInClippingHandlers.plugin> (not yet loaded)>: {
NSAppleScriptErrorAppName = Mail;
NSAppleScriptErrorBriefMessage = "Can\U2019t get project of message id 3604480 of mailbox \"INBOX\" of account \"Media Lab\".";
NSAppleScriptErrorMessage = "Mail got an error: Can\U2019t get project of message id 3604480 of mailbox \"INBOX\" of account \"Media Lab\".";
NSAppleScriptErrorNumber = -1728;
NSAppleScriptErrorRange = NSRange: {3139, 7};
}

Greg Jones 2011-07-25 01:26 AM

[QUOTE=joi;99920]I've tried to install the new plugin in Lion, but I'm getting this error...[/quote]

It is a problem with the MailTags 3.0 preview and the MailTags clipper script in OmniFocus. I've discussed this with the MailTags developer to see if the problem is with the script or with MailTags, but for now uncheck the 'Mail with MailTags' option in the Clippings preference.

dmfresco 2011-07-30 10:46 AM

Whenever I try to add the Omnifocus bundle, I get the following error:

For example, “I tried to drag the framistan onto the hee-whackity, the application didn't respond for about 10 seconds, and then it crashed. This is the third time it has crashed while I was trying to do the same thing, and it only started happening since I installed CrashDoubler 7.8!”

I copied the bundle from my Snow Leopard time machine backup manually, and Apple Mail in Lion is saying how it's being disabled each time I start up Mail. Nothing I do on two systems seems to make the bundle get installed or work.

dmfresco 2011-07-30 10:47 AM

The error message I get from Lion's Mail.

Mail has disabled the following plug-ins:

OmniMailMessageServiceEnabler

Contact the makers of these plug-ins for versions that are compatible with Mail 5.0 and Message 5.0.


All times are GMT -8. The time now is 09:15 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.