The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   Omni Lounge (http://forums.omnigroup.com/forumdisplay.php?f=24)
-   -   Applescript Pointer - confirm Mail Account Before Sending (http://forums.omnigroup.com/showthread.php?t=23443)

philrob 2012-02-09 06:30 AM

Applescript Pointer - confirm Mail Account Before Sending
 
I have multiple personality disorder in that I work with a number of organisations, some of whom want me to use an email account on their systems.

So I have multiple accounts on mac mail.

Occasionally I forget to check which account the new mail is going to go from so the recipient gets a mail from philrob@companyA instead of philrob@companyB

I've done a quick google and not seen anything that makes sense.

I tried using outlook for company A, thunderbird for B, mac mail for C but that was too cumbersome and hogged resources.

Can anyone point me in the direction of some applescript that intercepts mail when I click the send button and says 'which account do you want to send this from' and makes me choose the account or alternatively a workaround that works?

Thanks in Advance

Phil

whpalmer4 2012-02-09 07:57 AM

Why not just click only on the account for the company you're working for at the moment, instead of the union of all of them? Make sure you have the "Send new messages from:" field in the Composing preferences set to "Account of selected mailbox" and your outgoing email will come from that account only unless you deliberately change it while composing a message. Additional bonus: you don't see all the mail relating to stuff you aren't working on for this employer!

[URL=http://imageshack.us/photo/my-images/209/screenshot20120209at854.png/][IMG]http://img209.imageshack.us/img209/3284/screenshot20120209at854.png[/IMG][/URL]

philrob 2012-02-09 10:12 AM

Thanks for the suggestion, however I normally kick off a new email with Ctrl-N and that just defaults to my first email account.

I've tested to see if having an account selected before hitting Ctrl-N works, but unfortunately it doesn't.

I'll do a search for 'attachment' checking scripts and see if they exist and can be bastardised to do what i want.

Any other suggestions gratefully accepted

whpalmer4 2012-02-09 12:42 PM

You must not have all the preferences set as I do, because it works correctly for me.

philrob 2012-02-09 12:51 PM

Bingo!! You were spot on.

I had an incorrect setting in Mail --> Preferences --> Composing

It needed to be set to Send new messages from: [Account of Selected Mailbox]

I just need to learn the habit of clicking on the correct mailbox before CMD-N to create a new mail.

Thanks


All times are GMT -8. The time now is 01:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.