The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Bookmark WebDav Sync forgets Password (http://forums.omnigroup.com/showthread.php?t=12661)

ionos 2009-05-28 08:48 AM

Bookmark WebDav Sync forgets Password
 
With today's Sneak preview of OW5.10, the WebDav bookmark sync does not remember the username/password information. Even with the "Remember" checkbox checked, it asks for the login information for the webdav server on every sync.

Product: OmniWeb-5.10
Tag:
Date: 2009-05-22 02:04:03 -0700
Builder: omnibuild
Host: tb104i.private.omnigroup.com
Revision: 113108

troyb 2009-05-28 10:30 AM

If OmniWeb has trouble connecting to the WebDAV I know it can sometimes ask for authentication over and over. Are you still having trouble with this or has it cleared up?

Ken Case 2009-05-29 12:19 PM

This has been happening for me for months as well, and when I get some spare cycles I'm planning to dive into the code to see if I can fix it.

I think the issue is related to an expired nonce when using digest authentication. OmniWeb fails its digest authentication attempt because its nonce has expired, and when it goes to regenerate its credentials it says "Oh, the last request for this URL failed; the login information must be wrong" and prompts for new informationórather than grabbing the perfectly valid information from the keychain. At least that's my theory, I haven't actually verified this in the code yet.


All times are GMT -8. The time now is 07:29 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.