The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Jumping tabs II (http://forums.omnigroup.com/showthread.php?t=2805)

daiyi666@yahoo.com 2007-02-10 08:25 PM

Jumping tabs II
 
This is starting to annoy me now. If a series of tabs are open and I click on a popup link, the tab will jump to the last tab in the series. Very troublesome since it involves going back to the tab originally selected, then clicking to view the popup.

Anyone else experiencing this?

JKT 2007-02-11 10:55 AM

This is a consequence of the new feature of opening target="_blank" links in new tabs rather than Windows and the lack of an update to the way tab opening is handled. Ideally, new tabs should be opened under the parent or, if they continue to be opened at the bottom of the list, when closed you should be returned to the parent.

daiyi666@yahoo.com 2007-02-11 06:49 PM

Thanks. Sometimes it works "properly." I noticed that for certain sites, after a new tab/window opens clicking on the "close window" button of that window (and associated tab) will close it and bring OW back to the parent. Are these not "_blank" links then?

Doesn't SafariStand offer some way to not open _blank links this way? Any way to implement this in OW? Are is this a separate issue altogether? I can't profess to understand; just find it mildly annoying, that's all.

JKT 2007-02-11 11:33 PM

Do you mean the "Close window" that is presented by the code in the window and not the close button on the tab?

If so, I guess it could be set up so that it puts you back in the original site and therefore jumps you to the correct tab - this isn't something I've noticed myself as I tend to use command-W to close my tabs.

There isn't any way for us to implement better tab handling in OmniWeb - something we'll have to wait for OmniGroup to implement.

daiyi666@yahoo.com 2007-02-12 06:00 AM

[QUOTE=JKT]Do you mean the "Close window" that is presented by the code in the window and not the close button on the tab?

If so, I guess it could be set up so that it puts you back in the original site and therefore jumps you to the correct tab - this isn't something I've noticed myself as I tend to use command-W to close my tabs.

There isn't any way for us to implement better tab handling in OmniWeb - something we'll have to wait for OmniGroup to implement.[/QUOTE]

Yes, I do mean "close window" shown in the actual window. That does work correctly. Is this different than the "_blank" referrer link that may be causing the odd behavior? I assumed the "close window" or "open window" was javascript, which might explain the difference in behavior.

Well, whatever it is, I hope it gets fixed in 5.6.

Thanks.


All times are GMT -8. The time now is 12:03 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.