The Omni Group Forums

The Omni Group Forums (
-   Bonjour sync (
-   -   No longer able to sync with my iPhone . . . (

rigel 2009-08-31 09:52 PM

Just to make sure I'm following you, would a USB-to-iphone connection count for what you're talking about? If so, quitting and restarting when they're both connected doesn't seem to change anything.

I should also note that Share Settings doesn't seem to work (nothing ever shows up in the list of potential names on the iphone) and that following the Send Settings link (which I end up having to type in by hand to Safari on the iPhone for reasons which are long to explain) does seem to trigger Omnifocus but I get the same "Unable to find sync server" error.

whpalmer4 2009-08-31 10:24 PM

Have you rebooted the Mac this problem is on lately? I did have a bit of trouble the other day where I could see the Mac from my iPod in the send settings step, but couldn't get any further. The issue turned out to be that I had run out of disk space and the process that runs the Bonjour sync server couldn't do anything useful except advertise its presence (it couldn't actually share the settings). Quitting the apps which had gobbled up too much swap space and restarting made everything happy again. Might be worth a shot just to rule out the possibility that something has happened to the sync server process, though I doubt it is the reason. Just to clarify: on your iPhone, after you've pushed the Share Settings button on your desktop, you never see "Bill Palmer@Bill-Palmer's-Macbook" (well, obviously the username and machine name will be different), you just see "Searching...", right?

Brian is suggesting a computer-to-computer wireless network, not cabling the iPhone up with the USB sync/charging cable, which doesn't do anything relevant here. Does the Mac in question have a wifi card installed?

Brian 2009-09-02 01:09 PM

Rigel, OmniFocus can't sync over a USB connection to your phone, though we wouldn't complain if Apple made that possible at some point. :-)

The help article I mentioned walks you through setting up a WiFi connection directly between the Mac and the iPhone without any base stations or other devices on the network in the middle.

As bill mentioned, though, it requires a Mac with a built-in wireless; sorry I didn't make that clearer!

phlange 2009-09-02 08:40 PM

this app relies heavily on sync'ing via the wireless network.
So synch'ing depends on network conditions.

rigel 2009-09-13 10:21 PM

Sorry for the delay in responding. Whee, software release dates at work!

Brian: My desktop has a wired connection; it doesn't possess built-in wireless, I don't think. I did manage to arrange syncing between it and my iPhone via Bonjour in the past, though, so I'm not sure what I did to pull that off.

whpalmer4: Rebooting didn't seem to change things. And yes, once I click Share Settings nothing at all appears to happen on the iPhone, including seeing "name@machinename". It stays at [I]Searching . . .[/I]

Brian 2009-09-18 05:43 PM

Hmmm... well, if the machine doesn't have built in wireless, you're basically going to want to make sure there isn't any additional software running on the machine which might be blocking network access (Little Snitch is one example of this sort of software).

Once those possibilities have been exhausted, you'd want to take a look at whatever routers, wireless access points, and so forth between the Mac and the iPhone. If one of them is running a firewall of some sort, that could prevent the two versions of OmniFocus from talking to each other...

spinnakerco 2009-12-02 05:50 PM

[QUOTE=rigel;65724]Hm . . . that seems to be causing a bit of a "chicken and egg" issue . . .

When I try to share database settings with my iPhone now, the Share Settings button in the Synchronization Preferences doesn't seem to go through. When I instead send the settings, it tries to sync but I still receive the same error: "Unable to synchronize database with server. -- Unable to find sync server."

Specifically, the error says: "Unable to find sync server. No server could be found that matches your sync settings. Please make sure that your sync server is awake and that Omnifocus is open."

Thanks for that suggestion, but so far I don't seem able to get that to work.[/QUOTE]

I encountered two different problems
1. OF on my Mac was throwing errors when I attempted to sync to my standard archive on my computer (Preferences>Sync) [I'd click disk, then click Bojour at which point my cursor would change to the pinwheel and then say that my computer wasn't able to find the proper data base (or something like that) and would point me to a error log (see below)
2. I could not get my iPhone to see my computer when performing a sync.

[Wed Dec 02 17:22:44 2009] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Wed Dec 02 17:22:44 2009] [warn] RSA server certificate CommonName (CN) `sp2-c-10-18-09' does NOT match server name!?

Note the past tense of encounter :).

Step one was to set up a computer to computer network (really just disconnecting my computer from my office wifi). This resolved the strange error message that the volume on my computer could not be found. [This is weird because this was totally local to my computer, so the fact that the wifi was contributing to the problem was a surprise to me, but whatever)

Step two to set my iphone to airplane mode, turn on wifi, and select the c2c network (For some reason, my phone didn't want to acknowledge the wifi connection when it had the opportunity to connect to a cellular signal...)

Step three - sync as normal.

Hope this helps!

rigel 2009-12-22 01:35 AM

Hey. Sorry to have not gotten back to anyone for a bit. I seem to be stuck at the same place again. :/

To review: I use OmniFocus on my iPhone and Mac. I sync via Bonjour. They are both connected to the same network (wired for Mac and wireless for iPhone) and seldom to ever experience issues with the connection itself.

I stereotypically experience the same issue many others do with having to press the sync button twice to have it sync, but I can deal with that.

Every once in a while -- like now -- it stops syncing at all.

I receive the "Unable to find sync server" error.

Last time, I solved this in a remarkably simple way . . . one which I can't find the documentation for now, of course. But it may have been as simple as resetting the database on the phone, or possibly just restarting OmniFocus.

Now I'm back to a point I think I was at before. I reset the phone database (something I don't even believe I needed to do, in retrospect) and now can't set up syncing in the first place. It doesn't find the desktop on the Sync With Mac screen, and when I try to set up manually, it lists the server, but trying to save throws the same "Unable to find sync server" error.

The last time I had this happen, I struggled for weeks and nearly stopped using OmniFocus in its entirety. Should I be rebuilding the database or something?


[B]Addendum:[/B] Even when I try to send settings and have it manually sync I receive that error. Aargh.

rigel 2009-12-22 12:07 PM

Well, the good news is it's working now.

The weird news is that while it didn't sync the same evening after wipe, it did sync the next morning after [I]doing nothing different[/I].


All times are GMT -8. The time now is 12:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.