The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus for iPhone (http://forums.omnigroup.com/forumdisplay.php?f=49)
-   -   Update 1.0.1 Wiped my iPhone Database - Can I recover from iPhone Backup? (http://forums.omnigroup.com/showthread.php?t=8967)

AlexG 2008-07-23 11:00 AM

Update 1.0.1 Wiped my iPhone Database - Can I recover from iPhone Backup?
 
Hi,

The title pretty much says it all. My iPhone 3G backed itself up a few times while I had OmniFocus installed, is it possible to recover my data entries from that file? If so, how do I go about doing that? I don't think Restore will do the trick, I think that just restores it to factory settings.

Hope you guys resolve the issue of database wipes with future updates. It's a good thing I've now signed up for MobileMe so I can backup to iDisk...

Lizard 2008-07-23 04:06 PM

In iTunes, you should be able to right-click on your phone and choose "Restore from Backup". This will give you an option of which backup to restore from. Unfortunately, it will restore your whole phone, not just OmniFocus data.

Anjan 2008-07-23 07:57 PM

Seems like the developers put in a lot of work for this 'fair priced' application at $19.99. Buyer's remorse yet? :cool:

JKT 2008-07-24 09:26 AM

I'm quickly developing reader's remorse whenever it comes to your posts - if you have nothing constructive to say in response to people's questions for help then please don't respond. If you wish to bitch and moan, then start your own thread.

irons 2008-07-24 11:22 AM

1.0.1 data erasure
 
I had a similar issue following the 1.0.1 update. The next time I turned on the iPod I was confronted with OF's first-run splash screen inviting me to start a new database or sync against an existing one.

After choosing to sync, I got a dialog containing only a cancel button, followed by a dialog complaining that no internet access was available (unlikely as far as I could tell, as the wifi indicator was still strong, and I wasn't aware of any comcastic misbehavior). My inbox was correctly badged with one overdue item. Then OF exited to the home screen.

After launching again, all data appeared to have synced normally, and I haven't observed any problems in the 12 hours since. Three cheers for frequent, defensive syncing.


All times are GMT -8. The time now is 11:18 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.