The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   Omni Frameworks (http://forums.omnigroup.com/forumdisplay.php?f=16)
-   -   How to integrate omnigroup to your own project ? (http://forums.omnigroup.com/showthread.php?t=20537)

vdaubry 2011-03-29 08:43 AM

How to integrate omnigroup to your own project ?
 
Hi,

I need to be able to write and read from a rtf file in iOS, i thought i could use :

OmniUI/iPad/RTF/OUIRTFReader
OmniUI/iPad/RTF/OUIRTFWriter


I managed to build the frameworks but i cant figure out how to integrate theses classes in my own project.

I added the following frameworks to my project :

OmniAppKit.framework
OmniFoundation.framework
OmniBase.framework

I still get some undefined identifier such as :

RCS_ID("$Id$");
OBINITIALIZE
OMNI_POOL_START

Is there any configuration i am supposed to be doing to use classes from Omnigroup ?

Thanks in advance,
Vincent

j3rm 2011-10-18 08:10 PM

hum...
 
I'd like to know the answer to this questions. I have an app built and I just need to convert Rich Text formatting from codes to something pretty the users will enjoy. Interesting that this post is 7 months old and no one from Omni ever responded to it.

Tim Wood 2011-10-20 08:24 AM

There is a sample text editor app that answers this question...

scorpiozj 2011-11-30 04:54 PM

I look into the TextEditor, and add the project, set the Build Setting, Build Phase. And still has the build error, like:
Implicit declaration of function 'OBASSERT' is invalid in C99.

Can you provide more details?

I use Xcode 4.3(4D1002), Lion 10.7.3(11D16)

thanks

count_fersen 2012-02-22 10:58 PM

Hello There,

Still no answer for this question? I tried to build the text editor workspace example but it produces 999+ error messages. Simple question yet interestingly there's no answer for this?

hankthetank 2012-10-15 04:32 PM

how to build the text editor
 
I know this thread is old -- when I tried building the text editor sample, I had no problems. Here's what I did...

I opened the XCode workspace:

Workspaces/TextEditor.xcworkspace

with XCode 4.4.1. and selected the "iPad 5.1 Simulator" in the target device popup menu, and hit command-R and it runs in the simulator without a hitch or a glitch.

adamwulf 2012-11-21 01:04 PM

The issue for me was making sure I had the other required frameworks linked. I don't know where this is documented, but I also needed:

libz.dylib
libxml2.dylib
SystemConfiguration.framework
MobileCoreServices.framework

That got rid of all the linking problems for me


All times are GMT -8. The time now is 10:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.