The Omni Group Forums

The Omni Group Forums (
-   OmniGraffle General (
-   -   When I click an shape why does it always think I want to edit the text? (

edgley 2012-04-23 03:54 PM

When I click an shape why does it always think I want to edit the text?
Most of the time I just want to move the shape.
So I end up have to press ESC to deselect then try selecting again.

Is there someway of changing the clicking a shape behaviour? I never have this problem in other s/w and its driving me nuts having to keep reselecting things.


whpalmer4 2012-04-23 09:13 PM

My guess is that you are double-clicking on items. A single click in my experience does not select the text, even if you click directly on the text. A double click will first select the item and then immediately select the text.

[URL=""]Stop it[/URL]! :-)

edgley 2012-04-24 02:21 AM

I am using the trackpad on my MBP.

I click once to select it, then when I do the double click to drag action, that is when the text is becoming highlighted instead.

I get what you are saying, but how the heck am I supposed to do it then?

john.gersh 2012-04-24 05:25 AM

In general, the trackpad works the same as a mouse does. Start a drag by clicking and holding, not double-clicking: click down and start dragging without letting your finger up.

There's an setting in the System Preferences trackpad settings that replaces clicking with tapping; you might want to explore that, too.

edgley 2012-04-24 05:51 AM

My bad; when I say click I mean tap; all these words for using a mouse; no wait, a track pad....

i like the idea of trying just tap and drag. i was doing the equivalent of left click right click old-skool.

If that works you have ended up removing a key press that I would have had to made, a bug thank you!

edgley 2012-04-24 06:35 AM

I have testing done.

On my Mac Pro, with the trackpad:[LIST]
I tap once to select the shape
I tap twice, and without letting up on the second tap slide the shape around
I am happy[/LIST]
On my MBP, with the built in trackpad:[LIST]
As above
So long as the zoom is less than 200%
When it goes over 200% it selects the text for me to edit rather than move shape
I not happy but at least can go back to working on sofa :)[/LIST]

whpalmer4 2012-04-24 07:03 AM

With the cursor somewhere over the shape, press the trackpad button down, do not release it, and use other fingers to move the shape around. Should work fine at any zoom level, with Magic TrackPad or built-in trackpad. With Magic Mouse or regular mouse, press the mouse button and drag the mouse around.

Think of it as actually sticking a handle on the shape and dragging it...

Note: I don't believe in the "One Finger Tap to Click" setting available for the built-in trackpad. If you have it turned on, good luck to you, my suggestions may not be ideal.

edgley 2012-04-24 07:08 AM

Well I do believe in it as I use in PS / LR and all the other programmes just fine and dandy.

The last thing I want to have to do is go to the physical effort of actually pushing down and clicking the trackpad when I can just gentle bounce a finger tip off it.

What I am now saying is that there is a difference behaviour in the way the programme responds to the same action on two different systems.

Works as expected on my Mac Pro but not as expected on my Macbook Pro.

whpalmer4 2012-04-24 07:43 AM

I find that it leads to lots of spurious mouse clicks, so I don't use it. If it works for you, that's all that matters but I'm not testing my suggestions with that setting.

I turned on One Finger Tap to Click and Dragging on both iMac (with MT) and MacBook Air and found it to work exactly as expected at all zoom levels, with the caveat that it is very easy to get an extra tap in there, which results in selecting the text. If your finger lifts on the second touch, that gets treated as a double click and you get the undesired text selection. I don't see any evidence that it behaves differently on different hardware, except to the degree that the sensitivity of the hardware to those accidental touches may differ. If I make sure to stick my finger on the second tap, it is 100% reliable. Of course, it is with the trackpad button, too, with no special care needed, and some days the trackpad button represents the bulk of my daily exercise :-)

edgley 2012-04-24 01:20 PM

Okay, not that I asked you to try my settings, but it would have probably been quicker too than to logon here and post that you are not going to :)
(actually I am not even sure what settings I have asked to be tested, I think I have my trackpad set to the same as you)

Support has come back with the reason for my problem.
It seems that I am doing the double click at a different spend on each machine.

I have turned up the speed on the MBP and now double tap slightly slower and it works every time; phewie!!

All times are GMT -8. The time now is 10:05 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.