The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Favorites disappearing (http://forums.omnigroup.com/showthread.php?t=15359)

avilewis 2010-02-18 04:12 AM

Favorites disappearing
 
Hi there,
I've been using OmniWeb very happily for about a year. In the last week, my favorites have been disappearing. The toolbar is selected in the View menu, and if I go to the Bookmarks menu, I can see the favorites in the folder there.
But they are not appearing in the toolbar.
Very frustrating - any help would be much appreciated.

avilewis 2010-02-18 04:23 AM

Correction: it's a toolbar problem affecting both the favorites toolbar and the location toolbar.
Both are present, but both are empty.
In the location toolbar, it says "Address:" but there is no window beside the word.

troyb 2010-02-18 11:18 AM

What version of OmniWeb are you using out of curiosity?
If you download and reinstall OmniWeb does the problem persist?

avilewis 2010-02-18 11:33 AM

5.10.1/GM-v622.10.
I'll try downloading a fresh copy and re-installing and report back.

Is it possible to export my favorites and re-import them, so I don't have to start all over? I see an Import command in the menus, but not an Export...

avilewis 2010-02-18 11:51 AM

Ok, before downloading a fresh copy, I noticed that my favorites were now completely gone - not just missing from the favorites bar, but from the bookmarks menu as well.

After downloading and installing the new copy, the navigation and location bars are back, but the favorites bar is still empty.

I'll re-build my favorites, but I fear they'll disappear again within a day or so.

troyb 2010-02-18 11:55 AM

The favorites are stored in an .html file in your application support folder:

~/Library/Application Support/OmniWeb/Favorites.html
~/Library/Application Support/OmniWeb/Server Bookmarks/Favorites.html (if you sync your bookmarks)

You can make a backup of that file.

troyb 2010-02-18 11:57 AM

Out of curiosity, are you syncing your bookmarks?

avilewis 2010-02-18 12:01 PM

Thanks for that, and yes - I do sync my bookmarks between my desktop and laptop. I was wondering if that could be involved.

troyb 2010-02-18 12:04 PM

Seems likely, are you using Mobile Me or some other WebDAV server?

avilewis 2010-02-18 12:06 PM

Yes, MobileMe.

Grail 2010-02-21 03:05 PM

Just chiming in with a "me too" - I sync bookmarks with MobileMe, and I've noticed that when my MacBook tries to connect to a wireless network that has no Internet connectivity (eg: my ADSL router is still booting up), I end up losing the bookmarks on the MacBook. Then when it [I]does[/I] get connectivity, it syncs the broken bookmarks with MobileMe, causing my other mac to lose the bookmarks too (I can watch it happen in real time).

I've found a temporary workaround is to quit OmniWeb on all computers (ahem... I should buy another licence, yes?), restore the backup on one computer. Then for each computer (starting with the one I've just restored bookmarks to): Start OmniWeb up, wait for the bookmarks to reappear, then quit OmniWeb.

If I leave OmniWeb running without bookmarks, it will helpfully delete the newly restored bookmarks when I quit the bookmarkless instance.

I'm now trying to replicate the exact conditions under which OmniWeb will delete my bookmarks.

avilewis 2010-02-21 03:07 PM

Sigh. 2 days later, bookmarks have all disappeared again.
Troy, can you suggest a fix? I see that other people are having this problem as well.

avilewis 2010-02-21 03:09 PM

Also, I don't quite understand why MobileMe syncing would be causing this issue - I'm just syncing my Safari bookmarks with MobileMe, not my OW bookmarks.

Grail 2010-02-21 03:16 PM

I can get the Favourites and Personal bookmarks lists to disappear by simply starting OmniWeb without an Internet connection. Making them stay disappeared is the tricky part.

But this doesn't explain why bookmarks would be disappearing for avilewis…

troyb 2010-02-22 08:31 AM

avilewis: Are you saying that you're not using the "Use .Mac iDisk" setting in the OmniWeb bookmark preference pane?

avilewis 2010-02-22 09:35 AM

Whoops - sorry, confused. I am of course using that pref.

tlee61 2010-03-02 01:54 AM

Same here
 
Same happened to me yesterday. Lost bookmarks and favorites--and there were a lot--on MacBook and iMac at home. Sync bookmarks through MobileMe.

When I attempted to re-load my favorites and bookmarks from the AppSupport files, they were wiped clean. I'm able to resuscitate from Time Machine, but wonder how to keep this from happening again. I noticed it first yesterday on the MacBook, which means I wasn't at my office, which was an issue.

Help!

avilewis 2010-03-02 09:04 AM

Well, after a few more days of normal operation, I've lost all my bookmarks and favorites again.

If OMNI is listening here, there is a known issue with MobileMe syncing!

I'm really sad, because OW has been my default browser for a year, and MobileMe syncing is the reason I took it up in the first place.

I'm going back to Safari, reluctantly, until either someone from Omni responds with good news, or someone else reports that the issue has been fixed.

Grail 2010-03-02 04:36 PM

My favourites just disappeared again. This time the only event that I can think of was my MacBook being "disconnected" from the WiFi: for some reason HardwareGrowler reported that the MacBook had been "connected" to the network with AP MAC address of 00:00:00:00:00:00, then a few seconds later was connected back to the correct WiFi, reallocated an address, and shortly afterwards when I opened the Favourites bar on my iMac (sitting on the desk beside my MacBook), all the favourites were gone.

For the meantime, I've been using BookDog to restore my Favourites (since I "backed up" to Safari).

Interestingly enough, when I quit OmniWeb on the MacBook (which has no favourites) and relaunch it, I see my old favourites there for a short period - up until about the time the saved workspace finishes loading. Then they all disappear. If I quit OmniWeb and start it up again, I see the same thing.

vsmith1 2010-03-02 11:18 PM

I'd also like to report that I'm having the same issue. I also had (just turned it off) .Mac iDisk syncing. But it's only recently been happening - in the last few weeks. I've used this for quite a while and now it's turned off. But I'd rather it was fixed.

Anndra 2010-03-06 07:07 AM

Another 'me too' I'm afraid, favourites are still listed in the Bookmarks menu, but have disappeared from the bookmarks bar. I am syncing using the iDisk preference in OmniWeb.

danhd123 2010-03-12 05:27 PM

Me too. My favorites were lost a few weeks ago, both in the toolbar, and then later from the menu. It happened just after my computer was forced by the network to change its hostname (quick disconnect and reconnect, and the DHCP server hadn't realized I was gone), which screwed up all sorts of syncing. Then within the past two days, the rest of my bookmarks disappeared. This is the first time in 8 years that OmniWeb has lost my bookmarks, and I'm not happy. I can rescue most of them from another computer, fortunately, but I know that if I start OmniWeb on that computer while it has an Internet connection, those bookmarks will disappear too - happened when I tried to rescue my Favorites.


All times are GMT -8. The time now is 10:43 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.