The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Clipping in Mac Mail (Lion 10.7 / OF 1.92) (http://forums.omnigroup.com/showthread.php?t=21707)

BadExec 2011-07-25 12:28 PM

Clipping in Mac Mail (Lion 10.7 / OF 1.92)
 
Seems that clipping behavior has gone all screwy in Lion.

At first the clipping didn't work at all. I uninstalled the clipper and then reinstalled it several times. I finally did get it to work, but it only works intermittently and there are some issues:

Issue 1: the clipper often will just not work at all
Issue 2: when it does work, attachments are not included (This was a very valuable feature in previous versions)
Issue 3: certain emails do not clip at all. Instead I see a dialog box in Mail that says "Copying messages from the server". with a timer bar in the dialog. Once the timer bar is full, the message goes away, but my email is not clipped.

Some helpful items:
My short cut is command + .
This is the same shortcut I have used since version 1 of OF
The attachment I am trying to include is a PPTX (power point file)
The email I noticed that wont clip at all is from Expedia.com


Before I get a bunch of people telling me what I already know and have tried, please read the following:
[LIST]
[*]yes, I did look for similar issues in the forums before posting this (most answers simply say re-install the clip-o-tron, see next bullet point)[*]yes I did un-install and re-install the clip-o-tron 3000 (multiple times)[*]yes I did restart the machine[*]yes I did make sure that my shortcut was listed and checked in keyboard shortcut settings in system prefs[*]yes I have restarted mail and OF (several times)[/LIST]

Brian 2011-07-25 05:19 PM

Sorry for the confusion and inconvenience!

Many apps use command-period as a shortcut for the "Cancel" button in their dialog boxes. Mail is one of the apps that supports that shortcut - my work machine is running 10.6, but I can use command-period to cancel out of dialog boxes.

Even if Snow Leopard used to forward that shortcut along to OmniFocus if there weren't any Cancel buttons visible, it's possible that Mail isn't doing so under Lion. If the message never makes it to OmniFocus, we can't respond to it. I'd suggest trying a different shortcut and see if Mail handles that better. Perhaps Command-Control-Period or something along those lines?

Regarding the missing attachments - in OF version 1.9.1, we tried to work around a bug in Mail which could cause this; it may be that our fix doesn't cover one or more cases that you're hitting. If you contact the [EMAIL="omnifocus@omnigroup.com"]support ninjas[/EMAIL], we'd love to investigate this with you.

(Ditto for issue #3 - haven't heard of that phenomenon, so we'd love to investigate.)

johnbramhall 2011-07-26 12:18 PM

In my case, using OSX 10.7 with the most recent version of OmniFocus, .doc attachments come over with the clipping to the OF Inbox, but not .pdf attachments to the same email message.

BadExec 2011-08-04 09:01 PM

Brian, thank you! You are awesome. I tried a few different shortcuts, but no luck. Seems like no matter what you do the clipper won't work from the conversation view in Mail.app 5.0.

I emailed the support ninjas, so we will see what sort of ninja-awesomeness they can come up with.

Brian 2011-08-05 03:13 PM

I saw this on my Mac - it seems that (at least initially) Mail doesn't treat items in the conversation sidebar as Text, so it's not willing to apply OmniFocus' clipping service to selections there, even with the clip-o-tron installed.

That said, after some fiddling around in the associated pane of System Preferences, it suddenly started working. (I wish I knew exactly what I did, but I don't.)

I'd suggest quitting both OmniFocus and Mail, then opening System Preferences -> Keyboard -> Keyboard Shortcuts and unchecking the box next to "Send to OmniFocus" (in the "Services" section.)

Check the box again, then launch OmniFocus and re-install the clip-o-tron and finally launch mail.

Also, burn some sage. Never hurts. ;-)

mt404 2011-08-08 09:59 AM

Same issue here
 
Not sure if there is a lot I can add to this, but I'm experiencing the same issue. No matter what I do I can't get the clip-o-tron to cut my messages in the new mail 5.0.
[LIST][*]Used a variety of keyboard shortcuts (cmd-opt-ctl-c, cmd-shift-opt-c, ...)[*]Reinstalled and removed the plugin[*]Restarted computer[/LIST]
Totally rely on this feature and am sad to see it not working.

Brian 2011-08-08 03:56 PM

Sorry for the trouble, mt404! If you email the [EMAIL="omnifocus@omnigroup.com"]support ninjas[/EMAIL], we'll be happy to investigate why it's not working on your Mac. (These problems tend to boil down to a specific configuration - keyboard shortcuts that don't work on your Mac may work just fine on someone else's...)

isadore.braun 2011-10-27 01:58 PM

[QUOTE=Brian;100313]I'd suggest quitting both OmniFocus and Mail, then opening System Preferences -> Keyboard -> Keyboard Shortcuts and unchecking the box next to "Send to OmniFocus" (in the "Services" section.)

Check the box again, then launch OmniFocus and re-install the clip-o-tron and finally launch mail.

Also, burn some sage. Never hurts. ;-)[/QUOTE]

Followed these instructions and it worked (I no longer need to highlight some text to clip email into Omni).

As an aside, I didn't burn sage.

Thanks.

Kazza 2011-11-16 03:23 PM

Hi all

Like pre-Lion I couldn't get it to work with any keyboard actions, but as the Service was there, I could get it to work with using an application keyboard shortcut. (Though even then it didn't work the first time after I've restarted Mail - so I do the first one manually from the File/Services menu, and then its fine after that. Weird, but acceptable).

Pre-Lion the comment field of the OmniFocus task always contained the mail message just as I saw it in Mail. So if there was a long conversation between me and one or more people, the last reply was at the top. Now, the latest email isn't always there, though there is a link to that email. So when I'm creating the task I need to stop and look and make a note to remind myself when I come back to look at a particular email rather than having it just there in OmniF.

(I hope I've explained this OK.... let me know if more info needed)

Now I realise that what I'm seeing in the OmniF comment field is probably just what Mail is sending over to OmF, but is there any way to get consistent content ? Does Apple need to be told anything?

Thanks
Kazza


All times are GMT -8. The time now is 06:26 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.