The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Clipping Problem (http://forums.omnigroup.com/showthread.php?t=16824)

kevinplarson 2010-07-21 11:31 AM

Clipping Problem
 
I'm using Chrome. But I tried in Pages, too.

I'm wanting to copy and quick entry. Won't work. I recorded control-option-space. Doesn't work.

Isn't it supposed to copy to the clipboard and then put in Omnifocus, or am I confused?

Brian 2010-07-21 01:17 PM

Sorry for the trouble here - there are a couple different things that could be going on here. First, try the steps in [URL="http://forums.omnigroup.com/showthread.php?t=13906"]this thread[/URL].

There's some additional Chrome-specific info available [URL="http://forums.omnigroup.com/showthread.php?t=16139&highlight=chrome"]here[/URL].

whpalmer4 2010-07-21 01:37 PM

[QUOTE=kevinplarson;80529]I'm using Chrome. But I tried in Pages, too.

I'm wanting to copy and quick entry. Won't work. I recorded control-option-space. Doesn't work.

Isn't it supposed to copy to the clipboard and then put in Omnifocus, or am I confused?[/QUOTE]

Perhaps you could be a bit more specific about exactly what you are doing. Pretend I can't see your fingers or screen :-) I think I know what you are doing, but can't be sure from your description.

There are two different places where you can record a key shortcut in OmniFocus: there's the clipping shortcut, and there's the quick entry shortcut. The quick entry shortcut (I use control-option-space) just brings up the quick entry window, but does not copy anything. The clipping shortcut (I use cmd-shift-, or as I think of it, cmd-<) copies the selected material into either the quick entry box [b]or[/b] directly into your inbox, depending on your settings in the Clippings Preferences pane in OmniFocus.

"But why doesn't it work?", I hear you saying. Pages set ups cmd-< and cmd-> as zoom commands, and so intercepts the shortcut instead of allowing you to send the clipping off to OmniFocus (or OmniOutliner, in the case of cmd->). If you use a different keyboard shortcut not used by Pages (cmd-option-<, for example) Pages will allow the clipping service to be invoked.

Chrome is a different matter. It doesn't intercept the keyboard shortcut, but when you have something other than a URL in the address bar selected, it tells the Services code that no services apply, and so the clipping service isn't available. I don't know why it does that, or how to change its behavior. I think it is a Google bug, not an Omni bug, because if I visit the same page in Safari and select the same text, all sorts of services (not just Omni's) are available.

kevinplarson 2010-07-22 07:26 AM

Clipping Problem
 
Well, I think I understand. So chrome doesn't work well, eh? I'm liking chrome because the Evernote clipper works SO well! Oh, well...

With Pages, does anyone know short-cuts well enough to know a good one?

I was trying to use control-space for quick entry and control-option-space for clipping, but that definitely doesn't work (for the latter).

whpalmer4 2010-07-22 08:42 AM

[QUOTE=kevinplarson;80572]I was trying to use control-space for quick entry and control-option-space for clipping, but that definitely doesn't work (for the latter).[/QUOTE]

I use control-option-space for quick entry, and a quick trial revealed that it works fine when Pages is the front-most application, so if you're having a problem using it in Pages, there must be something else going on. Does it work if you have a different application in front? Are you sure it recorded the shortcut successfully? If it did, it should show it in the recorder field when you reopen the Clipping preferences. If it shows "Click to record shortcut" then it didn't successfully record and set that shortcut. When I try using control-option-space as the clipping shortcut, it won't successfully record. It works fine as the quick entry shortcut, though. I have found some references to control-option-space being defined as "switch to next input source" something to do with multiple language keyboard support, perhaps? Doesn't really make it clear to me why it works for quick entry and not clipping...

If the only problem you have with using cmd-< is that it doesn't work in Pages, don't forget that you could just invoke the clipping service through the Services sub-menu under the Pages menu. If the bulk of your clipping is done in other applications, that might not be unacceptable (it's what I would do, because I like cmd-< and the only time I've clipped something from Pages is while trying to answer your post!)

kevinplarson 2010-07-23 08:49 AM

Yeah, this isn't recording the clipping shortcut and I have no idea why. It always says "click to record" and doesn't have one. But in "quick entry" it does.

Brian 2010-07-23 01:10 PM

Sorry for the trouble here, Kevin - if you [EMAIL="omnifocus@omnigroup.com"]email[/EMAIL] or call (800.315.6664) our support ninjas we can help figure out what's going on.


All times are GMT -8. The time now is 04:57 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.