The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   10.6.1 update and Mail Clipping (http://forums.omnigroup.com/showthread.php?t=13807)

wolfneuralnet 2009-09-10 01:30 PM

10.6.1 update and Mail Clipping
 
Looks like the update breaks the clip-o-tron (at least the bundle got kicked out upon restarting mail 4.1).

Is there a new build for this? Thanks!

xmas 2009-09-10 02:02 PM

We'll get a fix out as soon as possible. Sorry for not catching this.

[B][SIZE="5"][EDIT: This fix is no longer necessary, instead reinstall the Clip-O-Tron from the latest [URL="http://www.omnigroup.com/applications/omnifocus/download/sneakypeek/"]OmniFocus 1.7.4 sneaky peek[/URL].]
[/SIZE][/B]


In the meantime, if you need a workaround:

1. Reinstall the Clip-o-tron from OmniFocus
2. DO NOT launch Mail
3. go to: ~/Library/Mail/Bundles/OmniMailMessageServiceEnabler_106.mailbundle/Contents
4. Launch Terminal.app. (It's in your Utilities folder)
5. Paste the following into the window: [CODE]open -a TextEdit Info.plist[/CODE]
6. Hit Return to execute the command.
7. At this point, a new TextEdit window should appear. Scroll to the part where it says:
<key>SupportedPluginCompatibilityUUIDs</key>

and add :
<string>2610F061-32C6-4C6B-B90A-7A3102F9B9C8</string>
<string>99BB3782-6C16-4C6F-B910-25ED1C1CB38B</string>

under the other 2 strings, so the entire key looks like:

[code]
<key>SupportedPluginCompatibilityUUIDs</key>
<array>
<string>225E0A48-2CDB-44A6-8D99-A9BB8AF6BA04</string>
<string>B3F3FC72-315D-4323-BE85-7AB76090224D</string>
<string>2610F061-32C6-4C6B-B90A-7A3102F9B9C8</string>
<string>99BB3782-6C16-4C6F-B910-25ED1C1CB38B</string>
</array>
[/code]

8. Re-launch Mail

Again, sorry for this inconvenience, this is new for Snow Leopard, and we had no idea they'd be changing this so often. We're in the process of making sure that we stay updated for future Snow Leopard updates.

P.S. For those Advanced users who want to know, you can get these strings by running:
[code]
cat /Applications/Mail.app/Contents/Info.plist |grep UUID -A 1
cat /System/Library/Frameworks/Message.framework/Resources/Info.plist |grep UUID -A 1
[/code]

wolfneuralnet 2009-09-10 02:36 PM

Thanks for the prompt response XMas - will try it later. Sounds like an easy thing to include in the next SP build :)

Ken Case 2009-09-10 06:28 PM

The fix is included in the [URL="http://www.omnigroup.com/applications/omnifocus/download/sneakypeek/"]OmniFocus 1.7.4 sneaky peeks[/URL].

[EDIT: Woops, not yet! See below.]
[EDIT 2: OK, now it is!.]

dougray 2009-09-10 06:49 PM

Not sure why, but 1.7.4 didn't work for me. Mail is still disabling the bundle. Do I need to restart, or delete OF before installing the latest Sneakypeak?

Doug

derekr 2009-09-10 07:00 PM

Doug, if I'm not mistaken, reinstalling the Clip-O-Tron will work. (I'm just now downloading the SP update.)

Ken Case 2009-09-10 07:08 PM

[QUOTE=Ken Case;66603]The fix is included in the [URL="http://www.omnigroup.com/applications/omnifocus/download/sneakypeek/"]OmniFocus 1.7.4 sneaky peeks[/URL].[/QUOTE]

Woops, sorry, I misread a commit: the current source code for the Clip-O-Tron is fixed, but that's not the version which is bundled in the current 1.7.4 sneaky peek. We'll get it fixed soon.

ksrhee 2009-09-10 07:10 PM

[QUOTE=Ken Case;66608]Woops, sorry, I misread a commit: the current source code for the Clip-O-Tron is fixed, but that's not the version which is bundled in the current 1.7.4 sneaky peek. We'll get it fixed soon.[/QUOTE]

I can confirm this. I had to reinstall 1.73 and apply the work around. Now I updated to 1.74, but the preference panel says install Cliptron even though it's already installed. When I push install, it breaks the bundle again.

So, I left it alone in my second go around, and it works. However, this should be fixed in the next version.

Ken Case 2009-09-10 08:40 PM

OK, sorry about that! I just verified that the fix is working in the latest [URL="http://www.omnigroup.com/applications/omnifocus/download/sneakypeek/"]OmniFocus 1.7.4 sneaky peek[/URL] (starting with build 118695).

menza 2009-09-11 03:41 AM

I just downloaded and installed the most current sneaky peek build and my clipper is stil not working.


All times are GMT -8. The time now is 06:13 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.