The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb General (http://forums.omnigroup.com/forumdisplay.php?f=8)
-   -   Keyboard Shortcut Customization? (http://forums.omnigroup.com/showthread.php?t=2921)

jdh 2007-02-25 05:40 AM

Keyboard Shortcut Customization?
 
Apologies if this has already been covered, but I can't find any easy way to do this...

I recently returned to using OmniWeb, having otherwise been using Safari for the most part over the past year. Unfortunately, as much as I like OmniWeb there is one thing that has been driving me absolutely insane...

The current keyboard shortcut for "return to start page" is CMD-SHIFT-LEFT, but unfortunately in most other places where text is entered in OS X this same key binding is used to highlight text back to the beginning of the line. This has caused me to lose what I've been entering on several occasions, as I just tend to habitually go fro that key sequence when editing text (as an example, it's happened here three times alone - although at least this page seems to retain my text when I come back to it).

I can't seem to find any way to reassign this key binding, and I'm rapidly reaching the point where I'm going to have to return to Safari if I can't break this habit (which is hard to do, considering that every other editing-based program I use works in this respect).

Thanks for any assistance anybody can provide.

JKT 2007-02-25 06:56 AM

You could reassign the keyboard shortcut for Go to Start Page in System Preferences>Keyboard & Mouse>Keyboard shortcuts.

To do so, click the + button in the preferences window (bottom left), select OmniWeb from the Application: menu, type in the option for which you want to change the shortcut ([B]Go to Start Page[/B] which is in the History menu of OmniWeb), click the input box for the shortcut and then press the keys that you want to use as your new shortcut (e.g. add option to the current default) and it should show up in the entry box. Click Add. If OmniWeb was open at the time, you will need to quit and re-launch it for the change to take:

[img]http://homepage.mac.com/jtyzack/.Pictures/screenshots/OWkbschomepage.jpg[/img]

theloonyape 2007-03-24 08:51 PM

hi this is a lifesaver.

but why do you map these keys by default? being mac users you should know that these keys are widely used for text editting.

it's driving me nuts. i was typing an email for 5 times and i kept hitting ⌘← to go back to the start of the sentence but instead, it goes back to history and there goes my email.

theloonyape 2007-03-24 09:02 PM

ok,

i realised the problem is with the handling of gmail. no matter what i do (i.e. mapping the keyboard shortcuts), it still behaves the same way in gmail. please tell me how to turn off this keyboard shortcut thing, it's driving me nuts. and omnigroup should seriously look into _not_ mapping these keys by default

just when i thought i found a browser that can handle gmail's text editting without opening firefox...

troyb 2007-03-28 03:15 PM

The plain text editor is working fine for me. I think what you're seeing is an issue with the rich text editor in gmail which should be working better when we update WebKit the rendering engine OmniWeb is using. (Which we have planned for OmniWeb 5.6.)

Lizard 2007-03-28 05:41 PM

I'm not *sure* I'm parsing the problem right, but you can turn off gmail's keyboard shortcuts in the gmail settings page (see link in upper left corner of the page.


All times are GMT -8. The time now is 03:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.