The Omni Group Forums

The Omni Group Forums (
-   iDisk/MobileMe/.Mac Syncing (
-   -   What's a "forbidden" or "403" error when syncing with MobileMe/iDisk? (

giessler 2008-08-06 11:40 AM

What's a "forbidden" or "403" error when syncing with MobileMe/iDisk?
I just needed to switch my account to a prestine new one. After changing the username in the settings of either iPhone and Mac in OF I do get when syncing:

Unable to perfom WebDAV operation.
The server returned "forbidden" (403) in response to a request to "PROPFIND /MYUSERNAME/Documents/OmniFocus.ofocus".

Any ideas?


Lizard 2008-08-06 05:05 PM

Are your settings in the MobileMe or the Advanced section?
Did you switch over your MobileMe account name in System Preferences also?

giessler 2008-08-06 09:47 PM

[QUOTE=Lizard;44013]Are your settings in the MobileMe or the Advanced section? [/QUOTE]


[QUOTE=Lizard;44013]Did you switch over your MobileMe account name in System Preferences also?[/QUOTE]


ommo 2008-08-07 02:33 AM

same problem
I have the exact same problem after I use a new username in mobile me. Any help is appreciated.

UPDATE: I think I was still able to sync after having a new username in and the problem only really started after I downloaded the latest update in OMF>

Lizard 2008-08-07 11:03 AM

Can you put files on your iDisk directly from the Finder or the MobileMe website?

Also, check your keychain for any stored passwords for your old MobileMe account and remove them.

ommo 2008-08-07 06:06 PM

Same message on iPhone
Lizard, thank you for the suggestion. I deleted anything in reference to my old user name in my account appearing in Keychain and was able to sync OMFocus on iMac with

I then deleted OMF on my iPhone and re-installed it. When I tried to sync the OMF on my iPhone I still get the same message "Unable to synchronize database with server. Unable to perform WebDav Operation. The server returned "forbidden" (40 in response to a request to "PROPFIND ..........etc."

So I guess the problem is something in the iPhone which prevents OMF to sync with my new user name account.

OF on my iMac (at work) syncs with iDisk which in turns sync with my Mac Book Pro (at home) without problem. So the problem is not with iDisk but with the OF on iPhone.

Please HELP ! I have been spending way too much time on this at the expense of my work.

p.s. Just a thought - any point in erasing all content and settings of my iPhone by going to Settings - Reset - Erase all Content and Settings ?

Brian 2008-08-08 10:22 AM

It appears that the user name and password that OmniFocus for iPhone uses can get stuck on a particular value. If you enter a typo or if your login information changes, OmniFocus gets stuck using the bad/old information.

We're going to add some code in our next update that manually prompts you for another user name and password combo when we get a "403 forbidden" response to a sync.

For the time being, though, we'll work around the problem by doing the following:
In OmniFocus' settings screen, scroll down to the sync settings.
Tap "advanced", then enter "" into the "Location" field.
Tap 'done', then tap the sync button.

Your phone will attempt to contact our server for a sync; we'll prompt the phone to ask you for a new login and password.

Type in random gibberish for the user name and password - the point here is that we want our server to send you a 'bad password' response. (Do not type in the user name and password of the *account you're actually trying to sync with; we could read that data.)

In any case, when the password sheet comes down a second time, tap 'cancel', then set the phone up with the correct sync address and start a sync.

You should be asked for the user name and password to your sync location. Enter the new information and you should be back up and running.

Lizard 2008-08-08 10:38 AM

And once you do this, you'll want to rerun the CoalesceDatabase script that's posted several other places on the forums, because changing your sync settings in 1.0.2 causes your database to grow out of control until you smoosh your database.

Lizard 2008-08-08 10:40 AM

And yes, once 1.0.3 is out, you won't need to manually coalesce your database nearly so often. And instead of getting a 403 error, you should get a chance to re-enter your username/password.

EDIT: That fix didn't make 1.0.3. So you'll need this workaround a little longer.

ommo 2008-08-08 05:59 PM

It works !
It works, it works !!!! Thank you sooooo much.

All times are GMT -8. The time now is 02:10 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.