The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus Extras (http://forums.omnigroup.com/forumdisplay.php?f=44)
-   -   Applescript performance under Lion (http://forums.omnigroup.com/showthread.php?t=22231)

fudster 2011-09-26 04:10 PM

Applescript performance under Lion
 
Hi all,

Anyone noticed a (dramatic) degradation in Applescript performance after upgrading to Lion?

I have a dozen or so OmniFocus workflow scripts that I use daily, and they're painfully slow since going to Lion. Some of them take a minute or more to run, they were much faster before, most of them instant.

I'm a little surprised that my searching around hasn't turned up more people that have experienced this, around here. I have seen other complaints about Mail.app scripts being affected, (with no resolution).

RobTrew 2011-09-26 11:25 PM

If they are .scpt files which were originally compiled under a pre 10.7 version of the OS, it might just be worth recompiling. (Save to a text format [.applescript], and then Save As from text to compiled [.scpt] ).

Can't test this personally at the moment - I am staying well away from the unweaned 10.7 cub at the moment :-)

(but I notice that there are [URL="http://bit.ly/CubStillSucks"]reports[/URL] of 10.7 slowing scripts for apps like Mail and Bibdesk quite badly too).


Good luck !

[COLOR="White"]--[/COLOR]

fudster 2011-09-27 07:45 PM

Hey Rob - great suggestion, thanks. I recompiled most of my stuff earlier today - some stuff still lags (more than before) but I *think* I've noticed an improvement. I'll continue to keep an eye on it - if the difference seems decisive I'll report it back here.

Thanks again, cheers!


All times are GMT -8. The time now is 05:44 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.