The Omni Group Forums

The Omni Group Forums (
-   iDisk/MobileMe/.Mac Syncing (
-   -   "Unable to Read Document" (

kevindaly 2009-09-14 03:31 PM

"Unable to Read Document"
This just started for no apparent reason. I try to open OF on my mac and get the following error message:

"Unable to Read Document"

No root transactions found in “file://localhost/Users/Kevin/Library/Application%20Support/OmniFocus/OmniFocus.ofocus/”.

I saw the thread on a fix for a problem with too many or too few root transactions, but I can't get an OF screen to open up at all!?

Any help would be awesome.


Ken Case 2009-09-14 03:54 PM

This sounds like one of the sync errors that was fixed by OmniFocus 1.7.3. (That is, sync errors in OmniFocus 1.7.2 and earlier could cause this problem, while OmniFocus 1.7.3 won't.)

But if you've already encountered this problem, 1.7.3 can't fix it (it only prevents it): you'll need to find a database backup which didn't have the error (OmniFocus makes backups at least once a day by default) and restore your database from it.

Our tech support ninjas can walk you through this process by email ( or over the telephone (1-800-315-OMNI or +1 206 523-4152). They can also help you restore any edits that you had made since that backup.

(The basic process we use is this: move aside the corrupt database, keeping a copy around in case it has edits we'd like to restore later. Launch the app, creating a new database. Find your database backups in Documents/OmniFocus Backups, and double-click through the most recent backups until you find one that works. Use File->Revert to Database Backup to replace your main database with that backup. If that backup is missing some important edits, you can send it along with your corrupt database and any intermediate backups to our support ninjas, where they can stitch the edit history back together to build a restored copy which they'll send back to you.)

Hope this helps, and we're very sorry that you ran into this bug!

kevindaly 2009-09-14 05:08 PM

I have an email into support, I'm sure they can help me fix it. I'll send them this thread.

kevindaly 2009-09-15 09:29 AM

Problem Solved
Problem solved! Thanks. Good, easy support.

All times are GMT -8. The time now is 09:43 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.