The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   Omni Frameworks (http://forums.omnigroup.com/forumdisplay.php?f=16)
-   -   Lot of images not found when running sample TextEditor (http://forums.omnigroup.com/showthread.php?t=23325)

Paul Chow 2012-01-28 12:45 AM

Lot of images not found when running sample TextEditor
 
I can build the TextEditor sample on Xcode 4.2.1 (according to the instruction in README). However, when running the sample, I saw lot of assert fail messages on console. Below are some of them.

----

ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPickerBackgroundView.m:58
ASSERT failed: requires 'disclosureImage != nil', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPicker.m:1836
2012-01-28 17:26:04.685 TextEditor[13718:1a603] Still need to port -[OUIDocumentPicker updateTitle] at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPicker.m:1335: Make sure this gets called as the selection changes, documents are added/removed, whatever.
ASSERT failed: requires 'appMenuImage', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIAppController.m:278
2012-01-28 17:26:04.689 TextEditor[13718:1c203] Still need to port OFSDocumentStoreFileItem *_addFileItemWithURL(OFSDocumentStore *, NSMutableDictionary *, NSMutableDictionary *, NSMutableDictionary *, NSURL *, NSDate *) at /Users/test/OmniGroup/Frameworks/OmniFileStore/OFSDocumentStore.m:1039: Why are we redundantly checking the UTI of this file?
2012-01-28 17:26:04.690 TextEditor[13718:1c203] Still need to port OFSDocumentStoreFileItem *_addFileItemWithURL(OFSDocumentStore *, NSMutableDictionary *, NSMutableDictionary *, NSMutableDictionary *, NSURL *, NSDate *) at /Users/test/OmniGroup/Frameworks/OmniFileStore/OFSDocumentStore.m:1052: Since the result of this is controlled by the filter UI in the document picker, we should have different API to pass in an immutable mapping of UTI->Class or otherwise ensure this is thread-safe.
2012-01-28 17:26:04.733 TextEditor[13718:1a603] Still need to port __block_global_9 at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUISingleDocumentAppController.m:658: If the user turns iCloud off and then back on, we could still end up moving sample documents into iCloud
[Switching to process 13718 thread 0x1e107]
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPickerBackgroundView.m:58
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIToolbarButton.m:19
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIToolbarButton.m:26
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/Inspectors/OUIInspector.m:87
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPickerBackgroundView.m:58
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPickerBackgroundView.m:58
ASSERT failed: requires 'image', at /Users/test/OmniGroup/Frameworks/OmniUI/iPad/OUIDocumentPickerBackgroundView.m:58

-----


Please tell me where I can get the images or how I can fix this issue.


Thanks.

Tim Wood 2012-01-30 08:05 PM

These images should all be added to the bundle at build time, so if they aren't, something has gone wrong in the build. If you don't have any local edits to the framework source (git stat), then something may differ with your build environment that we aren't handling.

The images get exported from the OmniUI project via its "Copy Resources" build phase (a Copy Files phase that exports them into the products directory under Resources/$(PRODUCT_NAME)). When building the final app, the resources from all the static libraries should get merged into the app via its "Copy Library Resources" build phase (which is shell script build phase that runs OmniGroup/Scripts/CopyLibraryResources).

You should be able to look in your products directory to see if the images got exported -- if not, the problem may be with the first step, if so, then with the second.

SpiraMira 2012-01-31 02:04 PM

I had the same issue, and it seems like a whole bunch of images were deleted during a previous commit. So I recovered them and copied them into my resources directory:

OUIFilePickerBackground-*
OUIToolBarButton-*
OUIDocumentDelete
OUIDocumentDuplicate
OUIDocumentExport
some other toolbar buttons

see: [r159239] Lots of iCloud work, document picker performance/animation, fixes merged from internal branches
commit: 7530108

Paul Chow 2012-02-01 06:04 AM

Thanks for your advice.

Finally I included the images (from the iOS 4.x-banch) in the project and I can show the icons.

Tim Wood 2012-02-01 11:52 PM

Hrm; if I messed up the last github patch, my apologies!


All times are GMT -8. The time now is 02:09 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.