The Omni Group Forums

The Omni Group Forums (
-   Other WebDAV (
-   -   WebDav error after Mavericks update (

chaa 2014-02-21 04:01 AM

WebDav error after Mavericks update

I was using a webDav access to my own server under snow-leopard.
Evry thing was right.

Then I upgraded to Mavericks. That mean I had to upgrade to 3.0.2
Now I can't use the old database with omnifocus.

[INDENT]I tried to create a new share point with the new
It is reachable with safari (e.g: read only)
[/INDENT][B]The result in Omnifocus[/B] is :
[CODE]Unable to perform WebDAV operation.
The server returned méthode non autorisée (405)
in response to a request to PROPFIND /OmniFocus.ofocus.[/CODE]

[B]access_log and error_log in /private/var/log/apache2[/B]
When loading Omnifocus (it must initiate a sync process when starting), the access_log says :
[CODE] - - [21/Feb/2014:12:59:24 +0100] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 405 402 "-" "OmniFocus/ Darwin/10.9.1 (Macmini4%2C1) (ateliercma.local)" ::1 - - [21/Feb/2014:12:59:36 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.24 (Unix) PHP/5.4.17 mod_wsgi/3.3 Python/2.7.5 mod_ssl/2.2.24 OpenSSL/0.9.8y DAV/2 (internal dummy connection)" - - [21/Feb/2014:12:59:40 +0100] "GET /webdav/iCal/LogistiqueCMA.ics HTTP/1.1" 401 551 "-" "Mac OS X/10.8.5 (12F45) CalendarAgent/57" ::1 - - [21/Feb/2014:12:59:42 +0100] "OPTIONS * HTTP/1.0" 200 - "-" "Apache/2.2.24 (Unix) PHP/5.4.17 mod_wsgi/3.3 Python/2.7.5 mod_ssl/2.2.24 OpenSSL/0.9.8y DAV/2 (internal dummy connection)"[/CODE]
[B]while the error_log says nothing.[/B]

[B]When running the sync again, message of OmniFocus is[/B] (French OS, sorry):
[CODE]Unable to perform WebDAV operation.
The server returned "méthode non autorisée" (405)
in response to a request to "PROPFIND /webdav/OmniFocus.ofocus".[/CODE]
[B]While access_log says[/B] :
[CODE] - - [21/Feb/2014:13:12:05 +0100] "PROPFIND /webdav/OmniFocus.ofocus/ HTTP/1.1" 405 402 "-" "OmniFocus/ Darwin/10.9.1 (Macmini4%2C1) (ateliercma.local)"[/CODE]
[B]and error_log keep saying nothing.[/B]

Conclusion: It's not working and I haven't a clue of the reason.

[B][INDENT]Things I've done :[/INDENT][/B]

• I created a /Library/Server/Web/Config/apache2/[B]Omnifocus-dav.conf[/B] file like this:
[CODE]DavLockDB "/usr/var/DavLock"
Alias /webdav "/Library/Server/Web/Data/Sites/DAVLand/"
<Directory "/Library/Server/Web/Data/Sites/DAVLand/">
Dav On
Order Allow,Deny
Allow from all
AuthType Digest
AuthName CMA
AuthUserFile "/usr/user.passwd"
AuthDigestProvider file
Require user Focususers
BrowserMatch "Microsoft Data Access Internet Publishing Provider" redirect-carefully
BrowserMatch "MS FrontPage" redirect-carefully
BrowserMatch "^WebDrive" redirect-carefully
BrowserMatch "^WebDAVFS/1.[0123]" redirect-carefully
BrowserMatch "^gnome-vfs/1.0" redirect-carefully
BrowserMatch "^XML Spy" redirect-carefully
BrowserMatch "^Dreamweaver-WebDAV-SCM1" redirect-carefully[/CODE]

• Beside, I used :
[CODE]sudo htpasswd -c /usr/user.passwd Focususers[/CODE]
to record that password although the webDav folder is recorded as accessible to that Focususers in the website management window of

• I changed the rights of that user on that alias (DAVLand) in the "stockage" (french OS) window of :
…gave it a full control and aplied to childrens.
[B][INDENT]Note also that: [/INDENT][/B]
• the webdav site is published with a valid-autosigned-certificat for SSL ([SIZE="1"]same than CardDav and CalDav[/SIZE])
• the DNS is working
• the OmniFocus release is 1.10.6 (v77.90.23 r197991)
• the CardDav access ([SIZE="1"]SSL[/SIZE]) to AddressBook works
• the CalDav access ([SIZE="1"]SSL[/SIZE]) to CalendarAgent works

[INDENT][B]I really thought I could keep my database accessible because OmniFocus was announced as Mavericks-compatible.[/B]
[/INDENT]What did I missed ?

TIA, Chaa

Ken Case 2014-02-21 06:41 AM

Since you're getting "Method not allowed" despite setting "Dav On" for the appropriate <Directory> block, I wonder if there might be a [URL=""]<Limit>[/URL] or [URL=""]<LimitExcept>[/URL] directive somewhere in your Apache configuration which is restricting the [B]PROPFIND[/B] method? Or perhaps there's something which is trying to offer a variant URL (possibly based on the requestor's language) that ends up redirecting to an index.html or index.php and the PROPFIND method isn't allowed for that? (Unfortunately, there are a lot of ways that WebDAV can be misconfigured, and it's hard to guess at which thing might be wrong from just a small excerpt of the configuration files.)

Unfortunately, even if you get this particular issue solved, I'm afraid we've found that OS X Server's stock WebDAV sharing setup is buggy on Mavericks: it sets up proxy servers for each user, and its proxying behavior isn't very robust. (One of the problems is that it rewrites URLs when redirecting to the proxy, but it's not very careful about how it rewrites them so it ends up mangling URLs which contain the share name anywhere in the path. One of the other problems is that the forwarding proxy server can end up reporting the wrong status code when there's any sort of timeout or other exception.)

We recently posted a support article for configuring Apache WebDAV sharing by hand on a Mavericks server, which we've posted at [URL=""]Configuring WebDAV for OmniPresence Sync[/URL]. Following the instructions from that article should also work for setting up your own server to sync OmniFocus (or OmniPlan).

All times are GMT -8. The time now is 07:23 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.