The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniOutliner 3 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=9)
-   -   Can't format imported text from O.Graffle (http://forums.omnigroup.com/showthread.php?t=10903)

Giray 2008-12-24 12:53 AM

Can't format imported text from O.Graffle
 
1 Attachment(s)
I've created a moderately complex omnigraffle file. Exported it to oo3 format. Opened it in oo3 and I cannot change the format of any except Level 1 rows. Level 2 rows are not responding. Worse, I'm getting a very bizarre set of errors. The first is something to do with an illegal value and then I get this one that will not let me out... I have to force quit:
[QUOTE][B]Alert[/B]: -[OOLayoutManager _fillGlyphHoleForCharacterRange:startGlyphIndex:desiredNumberOfCharacters:] *** attempted glyph generation while textStorage is editing. It is not valid to cause the layoutManager to do glyph generation while the textStorage is editing (ie the textStorage has been sent a beginEditing message without a matching endEditing.)[/QUOTE]

DerekM 2008-12-24 12:17 PM

This is a bug in OmniGraffle's exporter to OO3 format. Font weights are being stored incorrectly and can end up as negative values when it should be between 1 and 14. OmniOutliner apparently can't handle this and you'll end up in a horrible state making you force quit. We'll try to get this fixed on both ends. Before exporting to OO3 format, you'll need to change the font weight on all the text to regular (the Typeface option in the font panel). Sorry for the trouble!


All times are GMT -8. The time now is 08:48 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.