The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   Other WebDAV (http://forums.omnigroup.com/forumdisplay.php?f=57)
-   -   List of free webDAV sync providers (http://forums.omnigroup.com/showthread.php?t=11054)

mickey 2008-07-13 05:23 PM

Free WebDAV: www.box.net doesn't work, host it yourself
 
I've heard hints about the free basic account at box.net.

Once signed up, I can use the Finder's Connect to Server command, specify [url]http://www.box.net/dav/[/url] as the url, [email]username@domain.foo[/email] / password, and it's mounted.

When I specify [url]http://www.box.net/dav/[/url] plus un/pw to OF Mac 102746 I get a 500 (internal server error) value.

This also happened when I tried my WebDAV-enabled 1and1.com account.

??

inshushinak 2008-07-13 09:21 PM

WebDAV works fine for me.
 
WebDAV is hard and lots of services, especially free ones or out of the box shared hosting, won't support the full standard, which is murky in any case.

I got OF working on my MBP and new iPhone in about 5 minutes using Concentric -- set up a dedicated user in my account just for OF (so I didn't have to give the iPhone access to anything else), set that user up with write access to one dir under SSL, and pointed both MBP and iPhone there. Voila! Synchronization, and surprisingly low delay to keep things up to date.


[QUOTE=mickey;40597]I've heard hints about the free basic account at box.net.

Once signed up, I can use the Finder's Connect to Server command, specify [url]http://www.box.net/dav/[/url] as the url, [email]username@domain.foo[/email] / password, and it's mounted.

When I specify [url]http://www.box.net/dav/[/url] plus un/pw to OF Mac 102746 I get a 500 (internal server error) value.

This also happened when I tried my WebDAV-enabled 1and1.com account.

??[/QUOTE]

mickey 2008-07-13 10:08 PM

Progress report. OF/Mac gets back a 500 error. Through Goliath, which itself gets an error, I see that the following files are created

OmniFocus.ofocus
-- OmniFocus.ofocus
---- OmniFocus.ofocus
------ OmniFocus.ofocus
------ 00000000000000=oGWK-aUWZD2+kQEr2O2cdqX.zip
------ 20080714055906=kQEr2O2cdqX+pMssXBEosom.zip
------ 20080714055918=pMssXBEosom+bkVrI6iH88x.zip
------ pqnbRZ4kJaR.client
-- 00000000000000=oGWK-aUWZD2+kQEr2O2cdqX.zip
Each time it fails it looks ilke it puts an OmniFocus.ofocus folder in the deepest one and populates it with four or five files.

OF/iPhone reports "Unable to read document. Unrecognizable file name "2008....zip"; should contain a date separator instead of '='. [Cancel]

I was hoping to test thing on 1and1.com, my ISP, but I'm hitting some problems and they're not being seriously helpful. They're trying, but while WebDAV is supported I suspect nobody's ever mentioned it to them.

If someone at OF wants to ping me for some direct testing with 1and1, please do so.

afternoon 2008-07-14 06:58 AM

When I tried box.net, I got a 404 initially. I have a folder called Documents, and the correct url turned out to be [url]https://www.box.net/dav//Documents[/url]. Anything without the 2 slashes results in a 404.

Unfortunately, I get the following error message:

Unable to synchronize database with server.

Unable to read document.

No root transactions found in [url]https://www.box.net/dav//Documents/OmniFocus.ofocus/[/url].

When the drive is mounted through Finder, no files are present in the directory.

physicistjedi 2008-07-18 01:51 PM

I'm still getting 500 "Internal server error". A .ofocus file is created but neither iPhone nor my Mac can read it back.
Is there anybody who succeeded with box.net or any other free service (if it exists)?

Best,
pj

Smhearty 2008-07-18 06:01 PM

I found that the best way to sync with WebDAV for free is to set up a WebDAV server on your mac. I followed the excellent instructions at [url]http://manas.tungare.name/blog/2008/07/10/howto-setup-webdav-on-mac-os-x-leopard-for-syncing-omnifocus-to-iphone/[/url]

physicistjedi 2008-07-18 08:21 PM

[QUOTE=Smhearty;41626]I found that the best way to sync with WebDAV for free is to set up a WebDAV server on your mac. I followed the excellent instructions at [url]http://manas.tungare.name/blog/2008/07/10/howto-setup-webdav-on-mac-os-x-leopard-for-syncing-omnifocus-to-iphone/[/url][/QUOTE]

I agree, but my only computer is a laptop which does not stay on all the time and I will want to pull the list when it is not. Since box.net is apparently the only free service, I hope Omni people will focus on box.net compatibility. I am actually a little bit disappointed because I paid for advertised WebDAV synchronization and I am even OK for being a paying beta tester, but the software is not working at all for me to start testing. Sigh!

physicistjedi 2008-07-18 08:27 PM

With the latest revision I am getting a more detailed error:

The box.net server returned "internal server error" (500) in response to a request to "MOVE /dav/OmniFocus/OmniFocus.ofocus/ksgwyxjGM_e.client-write-in-progress-d9wD8TgKCXn".

atomicpirate 2008-07-30 02:05 AM

[QUOTE=Smhearty;41626]I found that the best way to sync with WebDAV for free is to set up a WebDAV server on your mac. I followed the excellent instructions at [url]http://manas.tungare.name/blog/2008/07/10/howto-setup-webdav-on-mac-os-x-leopard-for-syncing-omnifocus-to-iphone/[/url][/QUOTE]

I followed those directions; however when I attempt to sync in OmniFocus to the local WebDAV server on my laptop, I get this error message:

Unable to perform WebDAV operation.

The 10.0.1.200 server returned "internal server error" (500) in response to a request to "MKCOL /webdav/OmniFocus.ofocus-copy-in-progress-g49xRZXFaXh".

atomicpirate 2008-07-30 02:23 PM

[QUOTE=atomicpirate;43070]I followed those directions; however when I attempt to sync in OmniFocus to the local WebDAV server on my laptop, I get this error message:

Unable to perform WebDAV operation.

The 10.0.1.200 server returned "internal server error" (500) in response to a request to "MKCOL /webdav/OmniFocus.ofocus-copy-in-progress-g49xRZXFaXh".[/QUOTE]

OK actually I lied. I didn't set the permissions as specified in step 6 the first time around (guess I was sloppy in my rush to get it working early this morning) and once I followed that step and restarted apache, things worked fine!


All times are GMT -8. The time now is 09:29 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.