The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Asian languages and Babelfish (http://forums.omnigroup.com/showthread.php?t=2829)

leeharveyosmond 2007-02-14 04:40 AM

Asian languages and Babelfish
 
[url]http://www.babelfish.altavista.com/[/url]

using OmniWeb-5.5.4-beta-1-v607.16

Grab some suitable Asian text. I recommend "Chinese (simplified)" and "Chinese (traditional)" from the bottom of [url]http://developer.apple.com/[/url] -- two similar strings of four glyphs, the one with the complicated second glyph is "Chinese (traditional)". Paste into the the Babelfish form and translate.

Using OmniWeb or the current Safari, one gets variously "A- A-", "S- S-", or "????". Using Firefox 1.5.0.8, one gets eg "Traditional Chinese".

According to tcpflow, the HTTP method is POST, the Content-Type is application/x-www-form-urlencoded, and there is a suitable content length header.

Message body sent by OmniWeb:
doit=done&intl=1&tt=urltext&trtext=%E7%B9%81%E9%AB%94%E4%B8%AD%E6%96%87&lp=zt_en&btnTrTxt=Translate

Message body sent by Firefox:
doit=done&intl=1&tt=urltext&trtext=%26%2332321%3B%26%2339636%3B%26%2320013%3B%26%2325991%3B&lp=zt_en&btnTrTxt=Translate


It appears OmniWeb and Safari are sending 8bit data, and Firefox is doing something else.


All times are GMT -8. The time now is 03:39 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.