The Omni Group Forums

The Omni Group Forums (
-   OmniFocus 1 for Mac (
-   -   Old-format transactions must be upgraded before opening. (

anakin44011 2008-07-11 11:15 AM

Old-format transactions must be upgraded before opening.
I just upgraded to 1.1 in order to sync with my iphone and I'm getting this message:

Old-format transactions must be upgraded before opening.

When I first upgraded to 1.1, it told me of the new format, which I upgraded to, but apparently something went amiss. Any ideas how to fix this. The message is now popping up even when I'm not trying to sync.

anakin44011 2008-07-11 11:20 AM

Sorry, I forgot to mention. The header of the message reads:

Unable to read document

I'm not sure what document it is trying to read since OF is open and I'm using it (but alas not yet syncing with iphone)

gofargogo 2008-07-11 11:23 AM

I'm having the same problem. The notice pops up every minute or so. I've tried closing OF, discarding my updated database, and re-upgrading, but the problem persists.

Tampico 2008-07-11 12:21 PM

Me too. Same problem.

Brian 2008-07-11 12:31 PM

I'm sorry for the trouble here, guys. Can you do me the favor of trying the following, then sending the results in an email to [EMAIL=""][/EMAIL]?

We'll take a look at that information and try to determine what's going on here.
[LIST=1][*]Open your Applications folder, then the Utilities folder it contains.[*]Launch the application named Terminal[*]Paste the next two lines into the Terminal window, hitting Return after each.[INDENT][CODE]cd ~/Library/Application\ Support/OmniFocus/OmniFocus.ofocus

/bin/ls -C1[/CODE]
[/INDENT][*] copy and paste the results of the second command into an email and send it to the address I linked above.[/LIST]
I may not be the person that reads that email, so briefly describe your problem and/or point the support ninja at this thread. We'll use that info to try and determine what's going on here.

Again, very sorry for the inconvenience this is causing.

Tampico 2008-07-11 01:41 PM

I have emailed the results from the terminal commands. I'm really hoping this will get resolved soon. I have so been looking forward having my OmniFocus actions on my iPhone. After suffering through Apple's 2.0 update problems this morning and now not being able to get my OF data down to my iPhone, I'm getting a little discouraged.

anakin44011 2008-07-11 02:11 PM

I hear what you are saying, but think of it this way. I wouldn't be nearly as anxious if I didn't use this program 12 times a day, which is a testament to how great the program really is. They'll fix it and get the sync working, and soon we'll wonder how in the heck anyone keeps track of their lives without Omnifocus and an iphone.

gofargogo 2008-07-11 03:56 PM


Ok, in hopes of getting something to sync. I've deleted all the files in ~/Library/Application Support/Omnifocus and reopened OF. It opened with the starter NAs (learn more about OF, merlin mann plug etc..) and after about a minute the error message came back.

I also tried to sync with my idisk, and then tried to sync my ipod with the data via the manual method, it prepared to sync, then failed with the same "unable to read document." message.

However, if I turn off syncing with idisk (by using the reset button, as all other options were greyed out), the message stops.

So syncing may be the culprit here, not nec. old data.

I'm ok with entering all my data by hand on my computer into the sneaky peek version if I could get it to work before I left work for the weekend.

gofargogo 2008-07-11 04:55 PM

Ah ha! Updated to the latest (as of 4:45pm) sneaky-peek, and now when I turn on syncing it tells me of a particular item that needs updating:
Unable to read document. Old-format transaction file "root=99A135D5-AFDA-496A-B2F7-1D99CBD10D0D:1EF5EADA-8642-4953-B5DD-7CCA610BC01D.xml" must be upgraded before opening.

Tampico 2008-07-11 05:01 PM

They added some code to collect additional info since they haven't been able to reproduce the error. Here is what I got after this evenings update:

Old-format transaction file "051A0CF3-293B-4769-A45F-2275243D365C:FFEB9BA9-36C2-403D-B62E-924216B8F1DD.xml" must be upgraded before opening.

I'll be running the console commands and emailing it in to support.

gofargogo 2008-07-11 05:07 PM

I'm going to copy my backups onto a thumb drive, and then nuke my installation from orbit and see what happens with a fresh install from the latest sneaky peek.

Brian 2008-07-11 05:14 PM

GoFarGoGo, before you do that, just try setting the copy of the information on your iDisk aside - inside the documents folder, rename the "OmniFocus" folder to "OmniFocus - Old".

Does sync work now?

Tampico 2008-07-11 05:22 PM

[QUOTE=Brian;40188]GoFarGoGo, before you do that, just try setting the copy of the information on your iDisk aside - inside the documents folder, rename the "OmniFocus" folder to "OmniFocus - Old".

Does sync work now?[/QUOTE]

That worked for me. I had an recent backup copy of the OF database at idisk. I just deleted that and sync to iDisk finally worked.


gofargogo 2008-07-11 05:24 PM

Always the voice of reason and restraint...

Hm. Odd. There is no folder named OmniFocus on my idisk. There are old backups of .ofocus docs from two months ago, but nothing recent.

Ah, but trying to move the Omnifocus.ofocus doc dated May 22 doesn't work because it's 'in use', I think I'm getting close....

I can't seem to delete or change the name of this file. How frustrating...

Ok two reboots & one Finder lockup later. I was able to rename the file. Now the desktop client has synced...and ipod says it synced, but no projects or actions.

So now I'll move over into the syncing problem threads and do some reading.

Thanks Omni for helping out today, I know it can't have been an easy day for all of you.

Epilogue: Ok, doing the rubber chicken dance over my computer, updating to these evenings release and resyncing my computer, then resetting the ipod database and resyncing finally made everything show up correctly.

WHooo! Now I can start getting things done! :)

anakin44011 2008-07-14 07:17 AM

That did it. I had a file on my iDisk with the name Omnifocus. I renamed it and now syncing works. Thanks a bunch.

kt103099 2008-07-19 10:56 AM

Finally got mine working, but I had to go a step further. After I deleted everything on my iDisk related to OmniFocus, I still got this message:

Unable to read document.

Old-format transaction file "root=14E791F6-6093-475E-8F5C-EDD95D013904:76D7D552-4607-43AD-B74A-CF92539F67A1.xml" must be upgraded before opening.

Then I deleted all _local_ backup files and finally it sync'd succesfully.

All times are GMT -8. The time now is 12:26 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.