The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Excessive crashing (http://forums.omnigroup.com/showthread.php?t=6477)

madler 2007-12-27 04:10 PM

Excessive crashing
 
Is it just me, or is OmniWeb crashing much more frequently since the 2007-009 security updates? (I installed the 1.0, then the 1.1 version of that update.) Safari is also crashing excessively. I have the latest versions of both. I have sent in seven crashcatcher reports in the last week.

I suppose that the best way to make a browser secure is to make it unusable. If these problems are due to the security updates, then I can say this new approach to security is working very well.

troyb 2007-12-27 10:25 PM

Are you using a page or have one loaded that is running a java applet perhaps? Does closing this window help you at all?

theonehorst 2007-12-27 10:27 PM

No problems on my system. No change afterall.

MacOS 10.5

Forrest 2007-12-31 12:07 PM

I've been crashing a lot today, including a workspace that loaded fine a few days ago. I think it might have to do with a recent update.

Forrest 2007-12-31 12:40 PM

I just applied the latest OW update and I can again load the culprit workspace.

retroleum 2008-01-01 02:05 PM

Crashing randomly for a while now...
 
OmniWeb has been crashing and freezing for me since I think version 5.5.4. It started sometime last summer and has just been getting worse. It improved a bit after upgrading to version 5.6, but I now get AT MOST a week of use out of OmniWeb before I need to delete all of the associated files under Library/Caches/ for it to open and run at a decent speed. Today, I had to delete its files under Application Support as well, since it kept freezing on launch (I already had session saving deactivated, but it would not even open a blank browser window).

Problems only seem to occur when multiple tabs are open, but do not seem dependent on the websites open. Sometimes, the culprit is a website with excessive scripting (YouTube videos make OW jump crazily in CPU usage and often freeze it, but no other Flash-based videos do this and YouTube does not have this effect in my other browsers), but recently, OW has been freezing on pages it has had no trouble with before. Mostly, it just freezes, but it has crashed and quit itself quite a few times as well.

I'm using a PowerBook G4, 1.5GHz with 1.25 GB of RAM. OmniWeb used to be one of the fastest browsers on my computer, but now it seems to be getting slower and slower the more I use it. The other browsers I use a lot (Firefox 2, Safari 3, Shiira) have their own share of freezing and crashing, but the problems have not INCREASED for the other browsers since the first day I used their latest versions, which leads me to think it is not necessarily a problem with my system. I've been using OnyX to help with general system slowdowns... but it hasn't helped OW performance noticeably. I don't know if there's anything else I can personally do to help OW, so I'm hoping an update or something will fix it.


All times are GMT -8. The time now is 12:55 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.