The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Start/Due dates won't fit on a single line (http://forums.omnigroup.com/showthread.php?t=20416)

hackeron 2011-03-15 09:35 PM

Start/Due dates won't fit on a single line
 
I added the columns Start Date and Due Date to my Projects perspective, and this is what I see:

[url]http://itstar.co.uk/omnifocus_date.png[/url]

The date just won't fit on a single line, I tried resizing the window, I tried changing the font size and fonts, nothing :(

It shows up as:

14/04/201
1

How do I get the dates to fit in a single line?

EDIT: Changing the font from the default to Helvetica fixes this problem - is this a bug?

whpalmer4 2011-03-15 11:00 PM

No, not a bug. You're using a date format that results in a longer string than will fit in the default column size with the default font setup. With a 2 digit year you'd be fine, with a smaller font size you'd be fine, or with a wider column width, you'd be fine.

To adjust the column width, make sure you have the column labels showing (turn on the view bar with View->Show View Bar), then drag the separator between the column labels as necessary. Getting the settings to stick is a little bit fiddly; a perspective will save and restore the columns if you have the Restore Layout box checked in the perspective. To set the default settings, you need to close all but one window, set the columns as you want them, then close that last window. You would be forgiven for thinking that wasn't immediately obvious :-)

You do a similar drill for setting up the columns in the Quick Entry box—bring up the QE box, make your changes, close it without creating any new actions. To adjust the column widths, you need to be in OmniFocus as the frontmost application when you bring it up.

hackeron 2011-03-16 06:19 AM

[QUOTE=whpalmer4;94787]No, not a bug. You're using a date format that results in a longer string than will fit in the default column size with the default font setup. With a 2 digit year you'd be fine, with a smaller font size you'd be fine, or with a wider column width, you'd be fine.[/QUOTE]

I typed in 7d, I didn't request a 4 letter year, it seems to be the system default - how do I change this to a 2 digit year?

[quote]To adjust the column width, make sure you have the column labels showing (turn on the view bar with View->Show View Bar), then drag the separator between the column labels as necessary. Getting the settings to stick is a little bit fiddly; a perspective will save and restore the columns if you have the Restore Layout box checked in the perspective. To set the default settings, you need to close all but one window, set the columns as you want them, then close that last window. You would be forgiven for thinking that wasn't immediately obvious :-) [/quote]

Thanks, will try that :)

whpalmer4 2011-03-16 07:59 AM

[QUOTE=hackeron;94806]I typed in 7d, I didn't request a 4 letter year, it seems to be the system default - how do I change this to a 2 digit year?[/QUOTE]
Yes, OmniFocus uses whatever the system date format is. Go to System Preferences, select Language & Text, select Formats, fiddle to your heart's content. Remember, however, that you're probably changing the date format for some other application(s) as well, so adjusting the column width might end up being the least objectionable solution.

hackeron 2011-03-16 07:23 PM

[QUOTE=whpalmer4;94811]Yes, OmniFocus uses whatever the system date format is. Go to System Preferences, select Language & Text, select Formats, fiddle to your heart's content. Remember, however, that you're probably changing the date format for some other application(s) as well, so adjusting the column width might end up being the least objectionable solution.[/QUOTE]

Adjusted the column width, thank you very much for your help :)


All times are GMT -8. The time now is 11:33 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.