The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniGraffle General (http://forums.omnigroup.com/forumdisplay.php?f=10)
-   -   SVG output is incorrect in FF, Camino (http://forums.omnigroup.com/showthread.php?t=3224)

sdpinpdx 2007-04-04 10:06 AM

SVG output is incorrect in FF, Camino
 
The SVG output I get from OG pro (4.1.2) looks wrong in both Camino and Firefox.

The text in my boxes is the wrong size (spilling out of the boxes) and my arrowheads aren't centered on the ends of my lines.

The JPEG output looks perfect.

These are the only SVG viewers I have handy, and they have common ancestors; so I don't know if this is an OG issue or a Mozilla issue.

Anyone seen this before?

Wim Lewis 2007-04-07 02:03 PM

The text is a known problem (font and fontsize selection in SVG is broken --- it's a hard problem, unfortunately). I haven't had a chance to look into the arrowheads and see whether it's an OG problem or a Mozilla problem.

Pieter Kuiper 2007-09-18 12:04 AM

I also encountered the arrowheads problem. It is an old problem of OmniGraffle. I tried a solution suggested by Vincent22 here in [URL="http://forums.omnigroup.com/showthread.php?t=2456"]SVG export/dot import[/URL].

But then the renderer on wikipedia commons only shows one half of the arrows: [URL="http://commons.wikimedia.org/wiki/Image:Pn_overgang.svg"]http://commons.wikimedia.org/wiki/Image:Pn_overgang.svg[/URL], although Firefox will display them as I had intended.

Lots of my Omnigraffle drawings have arrowsheads on them, and I would like to export them to SVG, without having to manually tinker in code that I do not really understand.


All times are GMT -8. The time now is 03:34 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.