The Omni Group Forums

The Omni Group Forums (
-   OmniFocus 1 for Mac (
-   -   error after upgrading to mavericks gm (

rCorteza 2013-10-04 01:47 AM

error after upgrading to mavericks gm

Just like the subject says I upgraded and find this:

Unable to read document.

Error reading XML: internal error: Huge input lookup

Would appreciate any help as all was working fine just 2 hours before upgrading thanks!


Lizard 2013-10-04 10:28 AM

Sorry! It seems the problem is that your main database file is over 10MB and the new XML library now handles that differently.

We're aware of this issue and working on a fix.

In the meantime, if you have another computer or iOS device syncing to the same database, you may be able to slim down your database enough to get it working on 10.9.

Attachments do not contribute to this size limit, so you'd need to look for actions with long notes, or perhaps an action that repeats frequently that you can delete.

If you'd like help with this process, our Support Humans can be reached at [email][/email] or
+1 206-523-4152 or +1 800-315-OMNI (until 5pm Pacific Time weekdays)

wilsonng 2013-10-04 04:47 PM

One way to slim down your database is:

File menu > Move Old Data to Archive...

This should help slim down the database by moving any old completed tasks to the Archival database.

You can always look at your archival database by selecting

FIle > Open Archive

I've found that when I'm on the go, I don't really refer to anything older than approximately 30 days. I'll always have 30 days of past completed tasks but no more than that. If I really need it, I'll tell a client that I'll look up my history when I get back to the office.

rCorteza 2013-10-04 09:09 PM

Thanks for the help. I don't sync with other Macs, but it seems all the data is stored in Application Support? Can I just temporarily move that over to another Mac and then clean up my database then move it back? Will that work?

rCorteza 2013-10-05 02:55 AM

Hi again,

Ok so I moved my database over to another Mac not running Mavericks and tried to slim it down. First thing I did was to archive older items which made no difference in database size. Then I tried to go through and look for large items and delete them but also made no difference. In fact, as a trial I deleted have of my entries still to no effect in reducing size. The one thing that did work was compacting database, but after I was excited and moved it back to Mavericks seems it was no longer compacted. Guess that only works on the local machine?

Any other suggestions would be great as now I cannot run Omni thanks,


wilsonng 2013-10-05 09:28 PM

I hope you saw the top thread in this forum:


It advises you to delay installing Mavericks until Omnigroup has a chance to release their update.

I usually wait about 1-2 weeks and check the web sites of my mission-critical apps for news of compatible releases before upgrading Mac OS X.

Since Apple has an October 15th event, Mavericks will probably be released on that date. The Golden Master was released earlier only to developers. This gives the software developers a chance to test for software compatibility and write updates.

I'm betting that we'll see a lot of software updates on October 15th.

I'm guessing that you are either a developer and downloaded Mavericks from the Apple Developer site or (ahem) obtained Mavericks through (ahem) ***other channels***? ;-)

rCorteza 2013-10-06 05:05 PM

Thanks for the help. All legit not to worry I have a dev account, but unfortunately didn't visit the forums before upgrading. If there's no workaround I'll just have to wait, but in case there is a way just let me know thanks!


All times are GMT -8. The time now is 05:49 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.