The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus 1 for Mac (http://forums.omnigroup.com/forumdisplay.php?f=38)
-   -   Slow OmniFocus performance on PowerPC? (http://forums.omnigroup.com/showthread.php?t=8234)

peteypolo 2008-06-19 02:34 PM

Slow OmniFocus performance on PowerPC?
 
I have a Power Mac G5 (2GHz dual core, PPC) with 4 GB RAM running 10.5.3, and a Macbook Pro (2 GHz dual core, Intel) with 2 GB RAM running 10.4.11. I bounce my OF database between the two machines depending if I'm at home or work, and the DB backup file is 304kb in size.

On the laptop, OF works just fine. But on the G5 it can be as slow as an old dog. The simple act of dragging a task from the inbox to a project causes the OmniFocus process to spike to 40% or 50% of CPU usage.

Other than plunking down $2500+ for a new rig, is there anything I can do to improve performance on the G5?

Lizard 2008-06-19 02:40 PM

Rebuild your database periodically. It's an option in the File menu. How often is periodically? That depends on how many changes you make in a given time period. I might guess at once per week to start, and if you notice mid-week that it's slowing down again, do it more often.

If you need more performance than that gives, collapse any groups (Projects, Folders, etc.) that you're not actively using.

peteypolo 2008-06-19 02:54 PM

Just running a search of the whole db pushes CPU usage to >95%. I'll give the rebuild a go, thank you.

...

Response time is definately faster post-rebuild, but it still uses all available CPU. Hmm...

Lizard 2008-06-19 04:06 PM

Take a sample while it's churning at 100% CPU and email it to [email]omnifocus@omnigroup.com[/email] so we can make sure OmniFocus isn't unnecessarily wasting time somewhere.

Humbro 2008-10-31 06:44 AM

I'm having the same problem, only worse. Doing pretty much anything in the side bar (apart from selecting a project) drives CPU-usage up to 100%, causing quite laggy performance.

I tried to rebuild the database, seemingly to no effect.

I'm sitting on a 2.1 GHz PowerPC iMac G5, running OSX 10.5.5. I do have Firefox running as well, consuming about 20% of CPU, as well as the Activity Monitor taking around 7%. There are a few other apps running, but all their processes are at under 1%.

Brian 2008-10-31 03:04 PM

I'm very sorry for the inconvenience this causes! The next time this happens, it would be quite helpful if you could send us the output of a "sample" command, so the lead developer can try to determine what OmniFocus is doing.

To do this, you'll want to do the following:

1) Go to your Applications folder --> Utilities folder--> and launch "Activity Monitor".
2) A window will open that shows all the applications running on your machine. In the list, select our application.
3) Click on the "Inspect" button on the toolbar
4) Another window will pop-up. Click the "Sample" button on the lower left corner.
5) When it's done taking the sample, click the "Save..." button on the top right and email the document it creates to the support ninjas. We'll have a look at it and figure out what's going on.

(Note: samples can be a large quantity of text, so please don't paste it into a forum post.)

convergent 2008-11-01 01:29 PM

Running OF on a PowerMac G5 dual 2.0ghz and it seems to run fine.

CatherineHC 2008-12-03 01:57 PM

Still slow here
 
On my Power PC G4 I've been frustrated by this for some time. I deleted all my completed and dropped tasks. Didn't make any noticeable difference. I rebuilt the file. A little bit better... but not enough. Will follow Brian's instructions.

curt.clifton 2008-12-03 03:13 PM

How large is your database? (Look in your home folder under Library/Application Support/OmniFocus for the file OmniFocus.ofocus.) Mine grew to several megabytes due to an oddness with the Sync mechanism, even though I'm not currently syncing to any other devices. Enabling Bonjour syncing with the database on the local machine caused the database to shrink to a few hundred kilobytes. After that, I turned off syncing and my database has stayed small.

Brian 2008-12-03 04:46 PM

If I'm remembering correctly, one of the folks having this problem sent in their database, and we were able to reproduce the behavior on one of our testing machines.

It turns out that they had a large number of actions in their inbox - I think it was in the neighborhood of 50. Only appears to affect PowerPC machines for some reason.

We do plan to make some changes to the code, but if folks do have a lot of items in the inbox, creating a Miscellaneous single-action list or otherwise processing them out of the inbox would be the suggested workaround.

(If you're having this problem and you don't have that many actions in the inbox, please mention it in your post and/or email to the support ninjas.)


All times are GMT -8. The time now is 01:54 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.