The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   OmniWeb crashes on same web site (http://forums.omnigroup.com/showthread.php?t=27371)

gvp1 2012-12-10 06:12 PM

OmniWeb crashes on same web site
 
Hi. I'm running OmniWeb 5.11.2 on Mac OS 10.4.11.

Every time I visit Memory Alpha (Star Trek Wiki), OmniWeb crashes, or it fails to respond, and I must do a force-quit.

I would be grateful for any help.

-g.

leeharveyosmond 2012-12-11 01:21 AM

I have OmniWeb/5.11.2/GM-v622.19.3 on 10.4.11/PPC, and that site doesn't cause me any problems.

Problem No1: cache rearrangement. If that site fetches lots of small files, and OmniWeb's disk cache is nearly out of space, OmniWeb can sometimes hang for 2-3 minutes while it prunes its disk cache. Are you familiar with Terminal.app? If you think this is happening, open Terminal.app and run "/usr/bin/sample OmniWeb 10" ... in the output, you should see lots of calls to WebKit code, and some to SQLite3. Fixes are (i) be patient and (ii) use the Flush Cache item on the main menu

Problem No2: ad blocking. If that site is fetching lots of banner ads, and many of them are Shockwave or Flash, OmniWeb doesn't really like that. If you're familiar with OmniWeb's Network Activity panel or Error Log window (menu items for these are on the Window menu) you could try working out from where the ads are being loaded, then use use Ad Blocking in Preferences to prevent them from being loaded.


All times are GMT -8. The time now is 01:45 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.