The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniFocus for iPhone (http://forums.omnigroup.com/forumdisplay.php?f=49)
-   -   Wrong time for recurring tasks (http://forums.omnigroup.com/showthread.php?t=10722)

vegaz 2008-11-28 03:46 AM

Hours of recurring tasks
 
The iPhone OF seems unable to understand the time of the recurring tasks, at least when they are set to repeat after 1 day... when a recurring task is marked as completed in OF for iPhone the new task is created in the correct day, but always at 00:00, and not at the "right" time.
I'm the only one here or is OF for iPhone really time-blind as far as recurring actions are concerned?

scrubbydog 2008-12-02 06:30 AM

Completing Recurring actions
 
Recurring items are synced up to my iPhone without any issues, However, if I complete them from my iPhone the times get messed up.

For instance I have a daily recurring task with a start time of 08:00 and due time of 22:00. Marking this task complete on my Mac generates a new task the following day starting at 08:00 and due at 22:00. This is as expected and good :) Syncing up to the iPhone at any step in the process perfectly reflects what is going on on my Mac.

However, when I complete the same daily recurring task from my iPhone a new task is created with a start date of 10:00 for todays date and a due date of 00:00 for tomorrow. Syncing this back to my Mac gives me the new task altogether with the original recurring item untouched. :confused:

The only way I have found to handle this behaviour is to only complete recurring items from my Mac :(

Apart from this single issue I am absolutely delighted with how OmniFocus works with my iPhone and I am not even bothered by [I]setting up[/I] recurring items from my Mac, if only I could [I]complete[/I] them from anywhere.

Please let me know if there is anything I can do to help resolve this issue.

Thanks for a great product

scrubbydog 2008-12-02 01:30 PM

You are not the only one experiencing this. I posted the same issue then noticed yours :o

vegaz 2008-12-03 04:44 AM

The Omni support has been duly informed :-)
A temporary workatound: set the interval repetition to 24 hours instead of 1 day.
It's not the same result, but is better than nothing.

Ken Case 2008-12-03 07:32 AM

We've fixed this for the next release. Thanks for reporting the issue!

scrubbydog 2008-12-04 11:49 AM

Nice one :)

scrubbydog 2008-12-09 11:19 PM

I have just tested this out on 1.1.4 and it works perfectly.

Thankyou :)


All times are GMT -8. The time now is 10:15 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.