The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniDictionary (http://forums.omnigroup.com/forumdisplay.php?f=13)
-   -   Snow Leopard Support? (http://forums.omnigroup.com/showthread.php?t=13911)

kohlgill 2009-09-09 03:59 PM

Snow Leopard Support?
 
This procedure doesn't seem to work for me. Is OD Snow Leopard-compliant?

Kohl

[QUOTE=Andrew;82]Instructions for remapping the "Define in OmniDictionary" Service shortcut key combination:
[LIST][*]Bring up System Preferences and navigate to the Keyboard & Mouse preferences.[*]Choose the Keyboard Shortcuts view.[*]Add a new entry with the following values:[LIST][*]Application: All Applications (or you can choose just a specific app if desired)[*]Menu Title: Define in OmniDictionary[*]Keyboard Shortcut: (whatever you want that doesn't conflict with existing shortcuts)[/LIST][*]Quit and restart any applications that are running in which you want to use the OmniDictionary Service.[/LIST]
You should now be able to use your newly-defined shortcut to invoke the OmniDictionary Service, assuming that you spelled the menu title exactly correctly, that there are no shortcut conflicts, and that you restarted the app in question if it was already running. (My test case here was to map the Service to command-6, and I confirmed that this worked in the current OmniWeb beta, just FYI.)

Due to the way Service menu items get cached (or have in the past; not entirely confident of how much of a problem this still is), you may need to bring up the Services menu once after (re)starting your application just to force it to be populated.

I was unable to use this to override OmniWeb's command-= mapping (much to my disappointment). I'm pretty sure that OmniWeb has special command-= handling to map it to command-+ since so many people complained about having to press the shift key to get the command-+ shortcut (and other apps had added the same shortcut). I don't know if you can override normal built-in shortcuts as I haven't explored that much.

-andrew[/QUOTE]

Brian 2009-09-18 06:30 PM

Snow Leopard makes some changes to the way that service shortcuts work compared to previous versions of Mac OS X.

To re-enable your keyboard shortcut, do the following:
[LIST=1][*]Open System Preferences from the Apple menu.[*]Select the "Keyboard" pane, and switch to the "Keyboard Shortcuts" tab.[*]Select "Services" in the list on the left. (Next to the icon that looks like a gear.)[*]With "Services" still selected, scroll the right hand pane until you see the "Text" grouping.
(There's a bug in 10.6.x which can cause this pane to be blank; see [URL="http://forums.omnigroup.com/showpost.php?p=67074&postcount=4"]this post[/URL] for what to do.)[*]Continue scrolling in the Text group until you see the "Define in OmniDictionary" entry.[*]If the box next to that item isn't checked, check it.[/LIST]


All times are GMT -8. The time now is 03:23 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.