The Omni Group Forums

The Omni Group Forums (
-   OmniFocus 1 for Mac (
-   -   Inconsistent Clipping with Apple Mail (

nickgrossman 2010-09-27 07:58 AM

Inconsistent Clipping with Apple Mail
Hi --

I am new to OmniFocus and am really loving it. It has enabled me to get to Inbox (double) Zero and I finally feel as though I have a rational view of my to-dos.

However, I am having problems getting clipping to work with Apple Mail. I have read all of the threads on the forums, and have tried all of the suggested fixes. However, I'm still not able to get Mail clipping to work consistently.

Here's my setup:

* OmniFocus 1.8/GM-v77.63
* Apple Mail Version 4.3 (1081)
* Mac OSX 10.6.4

My clipping shortcut key is Command-Shift-UpArrow

Here's the problem:

Sometimes, clipping works perfectly. The OmniFocus service, including shortcut key, shows up in the Mail->Services menu, and the hotkey works perfectly. When that's the case, life is good.

Other times, when I go to Mail->Services, I get a "Building..." (grayed out) message, and no list of services. Obviously, when this happens, I can't clip messages and I am sad.

I have not touched my OmniFocus settings, so this change seems to be happening independently of that, which makes me think this is a Mac problem, not an OmniFocus problem.

However, other hotkeys continue to work, even when the clipping command doesn't. The general OmniFocus Quick Entry shortcut (for me Command-Shift-K) always works, and my Quicksilver shortcut (Control-Space) continues to work. So it's a bit of a mystery to me why just the clipping shortcut is not working.

I'd really like to fix this, as it's an important part of my workflow, and having links back to emails makes omnifocus much much more useful.

Is anyone else having this problem? Is there a known fix?


whpalmer4 2010-09-27 09:15 AM

I've seen the "Building..." bit as well on occasion. I agree that it seems to be a Mac issue, but haven't seen it often enough to conclude much more than that. Googling about now, I see others encountering this issue with no mention of OmniFocus. One comment made was that cleaning caches seemed to cause this, at least for some users, and while I hadn't made that connection, I think that the last time I recall encountering this, I had just cleared my caches with Applejack. Do you use Applejack, or Onyx, or any of those sorts of tools to clear out caches?

Here are two external threads discussing techniques that have worked:



No endorsement of those suggestions is meant or implied, use at your own risk. That said, the suggestions in the Apple discussion forum post seem like they should cause no lasting harm, which is harder to claim about 3rd party system maintenance utilities!

All times are GMT -8. The time now is 04:21 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.