The Omni Group Forums

The Omni Group Forums (
-   OmniOutliner 3 for Mac (
-   -   SL - broken spotlight indexing [FIX: removing old version still installed] (

monti182 2010-02-26 03:25 AM

SL - broken spotlight indexing [FIX: removing old version still installed]
Hi there,

I've already contacted Omni's support (as I wasn't aware of the forum right here) and they couldn't help me out.

I'm experiencing the following problem: Spotlight has refused to index and search any OO files, most likely since my update to Snow Leopard.
I did a bit of research and found the spotlight plugin (that .mdimport) file within my 3.9.5 Version of OO.
I manually installed it to the appropriate place and did a reboot + a completely new indexing via "Spotless". Didn't help.
So I tried index one single folder with .oo3 files via the mdimport command and it gave me this:

Plugin '/Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter' [U][B]does not match current 64 bit architecture[/B][/U] to import type 'com.omnigroup.omnioutliner.oo3-package'.
'/Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter' should be updated. 'arch -i386 mdimport' may work as a work-around.
Incorrect start/end range ordering; fixing.

Now, I have to say, that indexing files of my other omni-products (omnigraffle and omnifocus) works just fine. Could it really be, that the import-plugin is 32-bit-only.
Btw, I'm running a 10.6.2, MacBook Unibody 2Ghz, 4GB and OO 3.9.5 Pro

Any help would be appreciated since I do need the searching-compatibility for studying.

Thank you very much, Max

whpalmer4 2010-02-26 07:20 AM

They couldn't help you out?!? I didn't know they were allowed to give up!

Are you intentionally booting your machine in 64-bit mode? What happens if you boot in 32-bit mode and ask Spotlight to reindex your OO documents?

monti182 2010-02-26 07:25 AM

Oh sorry, I forgot to mention, I do not intentionally boot in 64 bit. System profiler says:

64-Bit-Kernel and -Extensions: no

which probably means SL is running in 32 bit. I've definitely never changed anything concerning the 32/64 bit question apart from forcing Safari to run in 32 bit (allows add-blockers).
Therefore, I don't really know, why mdimport is bothered by OO 32-bit plug-in in the first place.
Well the support told me to do the obvious: re-index and hope for the best.

greets, max

DerekM 2010-02-26 09:52 AM

Looking into this.

DerekM 2010-02-26 10:21 AM

if you do
file /Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter/Contents/MacOS/OmniOutlinerMetadataImporter
from Terminal, what does it list?

monti182 2010-02-26 11:55 AM

I've also got a reply via mail from Brian. He asked me to do the same thing. Here's the outcome:

macbookmax:~ Max$ file /Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter/Contents/MacOS/OmniOutlinerMetadataImporter
/Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter/Contents/MacOS/OmniOutlinerMetadataImporter: Mach-O universal binary with 3 architectures
/Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter/Contents/MacOS/OmniOutlinerMetadataImporter (for architecture ppc): Mach-O bundle ppc
/Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter/Contents/MacOS/OmniOutlinerMetadataImporter (for architecture i386): Mach-O bundle i386
/Users/Max/Library/Spotlight/OmniOutlinerMetadataImporter.mdimporter/Contents/MacOS/OmniOutlinerMetadataImporter (for architecture x86_64): Mach-O 64-bit bundle x86_64

seems ok to me...

DerekM 2010-02-26 01:15 PM

Well, not that it helps, but I'm unable to get OmniGraffle or OmniFocus Spotlight plugins to work. I'm getting the same error you see for OO. But OmniOutliner works just fine for me :) Still looking into this.

DerekM 2010-02-26 01:30 PM

Well, despite getting that error for OmniGraffle, Spotlight is still indexing my files as I can type something into a OG file, save it, then instantly find what I typed with Spotlight. You did actually delete the Spotlight index before having it re-index right?

monti182 2010-02-26 01:35 PM

Yes, I did delete the index for sure with a utility called Spotless. Complete erase and re-index. Took an hour.
On my system, the importer for office documents behaves similarly: it produces this 64bit error but still indexes all office documents correctly.
I'm going to remove all mdimporters of OO from the library-folders and see wether mdimport -L is able to finde the mdimport-file within the app. Then I'm going to re-index.

monti182 2010-02-26 01:38 PM

Oh, I could have found something: There was an old version of OO rotting somewhere in the utilities folder and when I removed the library copies of the mdimporter, terminal said that mdimport was relying on the old 3.0.2 version. Let's see..

All times are GMT -8. The time now is 10:24 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.