The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniPlan General (http://forums.omnigroup.com/forumdisplay.php?f=37)
-   -   OmniPlan Server Repository: Publish Failure (http://forums.omnigroup.com/showthread.php?t=23127)

clifhirtle 2012-01-04 12:49 PM

OmniPlan Server Repository: Publish Failure
 
I must be missing something with the OmniPlan Server Repository capability, as far as I can tell it is pull only, no push beyond initial project publication.

Example...

I have a standard WebDAV server with full access, configured and 'test' capability works just fine, but after I add the "Sync with OmniPlan server repository" Publish/Update Action in and hit Save on the local file, I get the error:

"You need to update to the newest version of the project before publishing your changes."

So I go back, use "Project" -> "Update", make changes, local file updates, but changes never appear to make it back to the Server Repository.

In other words, if I close the local file, then use the File -> Open from Server Repository, the changes made to the local file are simply not there.

Assuming "Publish" means push to server, "Update" means pull from server, yet there does not appear any way of getting the server-side file updated with the local-side changes after the initial server push.

What am I missing here?

kentonho 2012-01-11 04:13 PM

OmniPlan Server Repository: Publish Failure
 
Just checking in to see whether you might have found a fix?

We're also running into the same issue. However, our WebDAV does work for the other Omni products like OmniFocus (Mac, iPad, iPhone), OmniGraffle (iPad), plus others like Pages (iPad, iPhone), iThoughts (iPad, iPhone), Finder, etc...

We can Publish and Delete, but we can't Update...

kentonho 2012-01-17 03:17 PM

We've done a number of experiments with different WebDAV setups and this is what we found:

CentOS 5.7, Apache 2.2.3 configured for WebDAV does NOT work. We reproduce the same issues above. 412, Precondition error during update.
CentOS 6.2, Apache 2.2.15 configured for WebDAV works!
CentOS 5.7, Apache 2.2.22, manually built and installed configured for WebDAV works!

For 2.2.15, the following can be referenced for the WebDAV setup:

[url]http://www.cyberciti.biz/faq/rhel-fedora-linux-apache-enable-webdav/[/url]

For 2.2.22, we used the "OSX" based as a reference for the WebDAV setup. OSX Lion comes with 2.2.20:

[url]http://manas.tungare.name/blog/howto-setup-webdav-on-mac-os-x/[/url]

(The default group for 2.2.22 is daemon:daemon, instead of www:www)

I hope this helps!



Kenton

psidnell 2012-04-21 08:28 AM

Hmm - I'm having this issue all of a sudden publishing to iCloud calendars - this morning it's fine, this afternoon it's not.

dask 2012-09-17 06:03 AM

I am also facing the same issue. Please share your experience if you have found any solution to this issue.


All times are GMT -8. The time now is 04:03 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.