The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniGraffle for iPad (http://forums.omnigroup.com/forumdisplay.php?f=60)
-   -   Font issues when emailing PDFs from OG for iPad (http://forums.omnigroup.com/showthread.php?t=16331)

kcwookie 2010-06-01 05:16 AM

Font issues when emailing PDFs from OG for iPad
 
1 Attachment(s)
No one, including me, can read pdf files created by OG on the iPad. It appears to be a font issue. I have to email the files to myself, open them in preview and send them to the final recipient from Preview. This may be an Adobe problem, but OG for the iPad is the only app that's created the problem.

Brian 2010-06-01 02:32 PM

KCWookie, I'm sorry for the trouble this is causing!

We're seeing reports of this problem in our applications as well as in Apple's iWork applications for the iPad. It appears that PDFs produced on the iPhone OS work there and in OS X's Preview.app.

Unfortunately, the embedded font information is not rendering properly in just about any other PDF viewer. (Anecdotally, we've heard that Helvetica Neue works better than standard Helvetica, if that helps.)

We have a bug open on this issue in our tracker, and we've communicated the problem to Apple. Unfortunately, this is very unlikely to be something we can fix in our own code; we believe it'll need to be fixed by a future Software Update for iPads.

There's some more information [URL="http://discussions.apple.com/thread.jspa?threadID=2389034&tstart=0"]here[/URL] on Apple's support forums, if it helps.

As a workaround in the meantime, if you have OmniGraffle for the Mac, you can create the document on the iPad, then perform the export using your Mac instead. Again, we're really sorry for the trouble this is causing.

hornfinger 2010-06-01 02:33 PM

I have actually had similar problems with Pages exporting to PDF but agreed it would be nice for this to work

Tez09 2010-08-17 09:22 AM

I am getting bullet points at the end of each line of text and when I open the PDF on my PC, I get an error about embedded fonts. I don't have Mac so hoping Apple can address this font issue in future iPad OS update.

sgecko 2010-08-17 07:03 PM

preferred fonts for windows use
 
i live/work in a dual world. love my macs, but have to use wintel at work. the problem i'm having is with fonts not translating well in the wintel world within the pdf's i'm making with the program. probably doesn't help that i'm still on xp at work.

does omni have a list of preferred fonts to use that would translate well? i've tried some of the obvious (for example; arial), but the pdf had dots added at the end of the text labels.

appreciate the help.

sgecko 2010-08-18 01:22 PM

sounds like i'm not the only one with this problem.

[url]http://forums.omnigroup.com/showthread.php?t=16331[/url]

sgecko 2010-08-18 01:24 PM

yep, same problem here. i keep trying other fonts, but no improvement. thanks for the info.

[url]http://forums.omnigroup.com/showthread.php?t=17413[/url]

Brian 2010-08-18 02:33 PM

sgecko, thanks for linking to that thread - I've edited the title of that one to make it more applicable to the problem you had. Gonna merge this thread with that one next...

Jesse 2010-09-22 10:18 PM

Yikes, this just created a huuuge issue for me not having access to the one Mac that might be able to export all the work done in a working session with a client and not knowing about this bug until too late.

As an irksome but useful [B]workaround[/B], if you save as a photo to the Photos app that comes bundled with the iPad and open the image up in that app, you can email a correct-looking image to yourself or a client from THAT app.

This would be a lovely feature workaround Omni Group could add to the app in the meantime to eliminate the Photo app step, too, in case y'all are taking requests.


All times are GMT -8. The time now is 09:14 AM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.