The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Bug Reports (http://forums.omnigroup.com/forumdisplay.php?f=27)
-   -   Javascript problems (http://forums.omnigroup.com/showthread.php?t=1946)

dteare 2006-10-23 04:34 PM

Javascript problems
 
Hi all,

I've just started using OmniWeb since I started developing a OmniWeb SIMBL plugin for my [URL="http://1passwd.com"]keychain on steroids[/URL] application.

So far I am really impressed with OmniWeb and would be happy to make it my default browser.

Unfortunately, I am experiencing many problems on pages that use a lot of JavaScript. Seth Godin's Squidoo and 37 Signals' Tadalist both fail to work with OW.

I would think these sites are popular enough that OW should support them.

If you want a really simple page that breaks, try my [URL="http://1passwd.com/home/news_letter"]subscription page[/URL]. It seems to be a problem with Ajax (which squidoo and tadalist use often).

I'm using 5.5 (v607).

Forrest 2006-10-23 04:44 PM

You mention [url=http://forums.omnigroup.com/search.php?searchid=20126]ajax[/url]. There are known issues with OW's version of WebKit and ajax. They are currently working on OW 5.5.1 with an even newer version of WebKit which should solve the ajax issues.

pheski 2006-10-23 07:05 PM

[QUOTE=Forrest]... which should solve the ajax issues.[/QUOTE]

Eagerly awaited...:)

Peter

pheski 2006-10-26 03:18 AM

[QUOTE=pheski]Eagerly awaited...:)

Peter[/QUOTE]

Happy camper here. Just tested OW 5.5.1 beta on the PostNuke Forum, which uses Ajax. Three tries, three successes. Fast and easy.

Thanks, team. OW is pretty near perfect.

Peter


All times are GMT -8. The time now is 02:35 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.