The Omni Group Forums

The Omni Group Forums (http://forums.omnigroup.com/index.php)
-   OmniWeb Feature Requests (http://forums.omnigroup.com/forumdisplay.php?f=28)
-   -   View PDF in Browser Window (http://forums.omnigroup.com/showthread.php?t=548)

Backspace 2006-05-19 09:08 AM

View PDF in Browser Window
 
I'd like it if OmniWeb would allow me to view PDF's in a browser window like safari does. I don't like having to download it and open it in another app even if it does it automattically. Seems like a waste to use another app simple to view a PDF.

andreas_g 2006-05-19 09:23 AM

just use the terminal and type "defaults write com.omnigroup.omniweb5 WebKitOmitPDFSupport -bool false"
omniweb then will open pdf files in the browser window instead of downloading them.

jphaag 2006-05-19 11:42 AM

You may also have a look at these plugins (which are free for personal & educational use):

[URL="http://www.schubert-it.com/products/"]http://www.schubert-it.com/products/[/URL]

hansit 2006-05-21 06:52 AM

In my Sneaky Peak 11 of OmniWeb 5.5, PDFs don't even download. All I get is an "Open" dialog box, not a "Save" dialog. I have to click "Cancel", and the browser window is going blank.

The "defaults write com.omnigroup.omniweb5 WebKitOmitPDFSupport -bool false" trick doesn't seem to work. At least, it doesn't change anything.

I'm using Schubert IT's PDF Browser Plugin (v. 2.2.3) which works well with OmniWeb 5.1.3 and all other browsers.

I assume this is a bug in the Sneaky Peak versions or, possibly, that they're not compatible with Schubert IT's PDF Browser Plugin?

Forrest 2006-05-22 11:27 AM

I use that plug-in, and it works fine. Do you have the AdobePDF plugin disabled?

hansit 2006-05-23 01:38 PM

[QUOTE=Forrest]I use that plug-in, and it works fine. Do you have the AdobePDF plugin disabled?[/QUOTE]

Yup. Adobe's plug-in is disabled. Today, I succeeded to get things working. Via OmniWeb > Preferences > Plug-Ins, I disabled Schubert IT's plug-in, then enabled Adobe's plug-in, and relaunched OmniWeb. PDFs still didn't show up in the browser. Then I disabled Adobe's plug-in and re-enabled Schubert IT's plug-in, relaunched OmniWeb, and now it all suddenly worked well. Go figure! :-)


All times are GMT -8. The time now is 03:16 PM.

Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2017, vBulletin Solutions, Inc.