View Single Post
I'm having the same problem. I'm using 10.5 (Leopard). When I watch the firewall logs and try to initiate a sync from my iphone, I see connections being denied. Most of the denied connections were on 49349, so I changed the omnifocus defaults using terminal:

defaults write com.omnigroup.OmniFocus SyncServerPort -int 49349

After doing that, I restarted omnifocus and checked the firewall logs and saw that that port was open:
May 6 13:03:13 Macintosh-96 Firewall[84]: httpd is listening from ::ffff: uid = 501 proto=6

However, when I tried to initiate a sync from my phone, I got another denied connection, but this time on a different port:
May 6 13:03:29 Macintosh-96 Firewall[84]: Deny connecting from uid = 0 proto=6

Just in case, after changing the default omnifocus port, I disabled the firewall, reset the iphone database, and re-sent the sync settings to my phone. This didn't change which port the iphone was trying to connect on.

Is there a solution for this? Obviously, I have my firewall GUI set to allow incoming connections for Omnifocus and I *have* successfully synced in the past. I'm not sure if it was the recent mac security update or the recent iphone omnifocus update that broke my sync, but I suspect it was one of them.