View Single Post
After looking into this, it appears that the OS X firewall changed behaviors at some point in the 10.6.x releases. It now blocks all web server connections unless the "Web Sharing" option is turned on in system preferences.

Even if OmniFocus is on the list of approved applications, you'll need to enable that option to bonjour sync. We're looking into ways we can do a better job of notifying the user when the firewall is preventing bonjour sync, but this does not appear to be something we can address in our code.