View Single Post
You've got automatic layout turned on. Bring up the Canvas inspector (command-3), select the Diagram Layout tab, uncheck the box for automatic layout. Some of the diagram templates have it turned on by default.